summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/amqp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/amqp')
-rw-r--r--dev-ruby/amqp/Manifest2
-rw-r--r--dev-ruby/amqp/amqp-1.4.0.ebuild40
-rw-r--r--dev-ruby/amqp/amqp-1.5.0.ebuild40
-rw-r--r--dev-ruby/amqp/metadata.xml5
4 files changed, 87 insertions, 0 deletions
diff --git a/dev-ruby/amqp/Manifest b/dev-ruby/amqp/Manifest
new file mode 100644
index 000000000000..fa173e86e7cd
--- /dev/null
+++ b/dev-ruby/amqp/Manifest
@@ -0,0 +1,2 @@
+DIST amqp-1.4.0.gem 1176576 SHA256 c79c45c9881c2c74ad2bbfdcee2fd11307d0e96760712902079a3e196dae37dc SHA512 456436d361b6b77ccf3004e4cb2110367f59653ba73bf8beb24745210f919f2039147f4527662f9c239b7fbb91d2b614ee60dbd05c071914df12cbc3640530f0 WHIRLPOOL 55d756df8cdee6f45b5c8ac3fbd8d3874aa671a93587d9e890f994bee57a72812a4b009fd8bf1c9d72f52ea11b367828f129b1724e865b4f128ee6af8e2fd857
+DIST amqp-1.5.0.gem 1177088 SHA256 0cc1bc1c2715dc5793d7dcbbc94c89b25cec71837e2ed53a4762812fb7e78c4a SHA512 9c5e7b46d2a6a4e316ff7e6ceee0d5e60808f489fb603089158ef0ab0b9ed8f8a8fda6907225f9e01ea2a2990b0fca7eee7576455a050e94544ba278752aeb59 WHIRLPOOL 7830e36917d8e4e637b1f138e6ba882ed5036e0f95560ea1236a15b1e4216218fb0d0b937551fa3b8946b4e07e9eb2c63071c421d9b747218b7554bea9c7d846
diff --git a/dev-ruby/amqp/amqp-1.4.0.ebuild b/dev-ruby/amqp/amqp-1.4.0.ebuild
new file mode 100644
index 000000000000..e97b5b5be00d
--- /dev/null
+++ b/dev-ruby/amqp/amqp-1.4.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit versionator ruby-fakegem
+
+DESCRIPTION="AMQP client implementation in Ruby/EventMachine"
+HOMEPAGE="http://amqp.rubyforge.org/"
+
+LICENSE="Ruby"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/multi_json dev-ruby/evented-spec )"
+ruby_add_rdepend ">=dev-ruby/eventmachine-0.12.4
+ >=dev-ruby/amq-protocol-1.9.2"
+
+all_ruby_prepare() {
+ #rm Gemfile || die
+ sed -i -e '/[Bb]undler/ s:^:#:' -e '/effin_utf8/ s:^:#:' spec/spec_helper.rb || die
+
+ # Many specs require a live rabbit server, but only root can start
+ # an instance. Skip these specs for now.
+ rm -rf spec/integration spec/unit/amqp/connection_spec.rb || die
+}
+
+all_ruby_install() {
+ dodoc -r docs examples
+}
diff --git a/dev-ruby/amqp/amqp-1.5.0.ebuild b/dev-ruby/amqp/amqp-1.5.0.ebuild
new file mode 100644
index 000000000000..6eb46179acf0
--- /dev/null
+++ b/dev-ruby/amqp/amqp-1.5.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit versionator ruby-fakegem
+
+DESCRIPTION="AMQP client implementation in Ruby/EventMachine"
+HOMEPAGE="http://rubyamqp.info/"
+
+LICENSE="Ruby"
+SLOT="1.4"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/multi_json dev-ruby/evented-spec )"
+ruby_add_rdepend ">=dev-ruby/eventmachine-0.12.4
+ >=dev-ruby/amq-protocol-1.9.2"
+
+all_ruby_prepare() {
+ #rm Gemfile || die
+ sed -i -e '/[Bb]undler/ s:^:#:' -e '/effin_utf8/ s:^:#:' spec/spec_helper.rb || die
+
+ # Many specs require a live rabbit server, but only root can start
+ # an instance. Skip these specs for now.
+ rm -rf spec/integration spec/unit/amqp/connection_spec.rb || die
+}
+
+all_ruby_install() {
+ dodoc -r docs examples
+}
diff --git a/dev-ruby/amqp/metadata.xml b/dev-ruby/amqp/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/amqp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>