summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-01-22 01:56:05 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-01-22 01:56:05 +0100
commitc3274991d07ee95c1266dbf35ce70b46c70a1f2f (patch)
treebc48beda7ab527f3bb8c9bc6dc5c5e4672c2f391 /dev-ruby/asciidoctor/asciidoctor-1.5.5-r1.ebuild
parentdev-ruby/wikicloth: Apply patch to fix tests (partially) (diff)
downloadgentoo-c3274991d07ee95c1266dbf35ce70b46c70a1f2f.tar.gz
gentoo-c3274991d07ee95c1266dbf35ce70b46c70a1f2f.tar.bz2
gentoo-c3274991d07ee95c1266dbf35ce70b46c70a1f2f.zip
dev-ruby/asciidoctor: Add ruby23, drop ruby20, drop ~arm
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-ruby/asciidoctor/asciidoctor-1.5.5-r1.ebuild')
-rw-r--r--dev-ruby/asciidoctor/asciidoctor-1.5.5-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/asciidoctor/asciidoctor-1.5.5-r1.ebuild b/dev-ruby/asciidoctor/asciidoctor-1.5.5-r1.ebuild
new file mode 100644
index 000000000000..f66c7eb4093a
--- /dev/null
+++ b/dev-ruby/asciidoctor/asciidoctor-1.5.5-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_TEST="test features"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.adoc README.adoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Processor for converting AsciiDoc into HTML 5, DocBook 4.5 and other formats"
+HOMEPAGE="https://github.com/asciidoctor/asciidoctor"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-util/cucumber
+ dev-ruby/rspec-expectations:*
+ dev-ruby/asciimath
+ dev-ruby/coderay
+ dev-ruby/erubis
+ dev-ruby/haml
+ dev-ruby/nokogiri
+ dev-ruby/slim
+ dev-ruby/tilt )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/asciidoctor.1
+}