summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-10-09 09:10:05 +0200
committerHans de Graaff <graaff@gentoo.org>2015-10-10 07:38:41 +0200
commiteeb7ed5a96cd37c4fceb5fba512d47c7f073db5a (patch)
tree70e2630e8443be2bf2e0368ed811057d0f0519ef /dev-ruby/bson/bson-3.2.6.ebuild
parentdev-ruby/bson: cleanup (diff)
downloadgentoo-eeb7ed5a96cd37c4fceb5fba512d47c7f073db5a.tar.gz
gentoo-eeb7ed5a96cd37c4fceb5fba512d47c7f073db5a.tar.bz2
gentoo-eeb7ed5a96cd37c4fceb5fba512d47c7f073db5a.zip
dev-ruby/bson: add 3.2.6
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-ruby/bson/bson-3.2.6.ebuild')
-rw-r--r--dev-ruby/bson/bson-3.2.6.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/bson/bson-3.2.6.ebuild b/dev-ruby/bson/bson-3.2.6.ebuild
new file mode 100644
index 000000000000..0627cb8ec76c
--- /dev/null
+++ b/dev-ruby/bson/bson-3.2.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+GITHUB_USER="mongodb"
+GITHUB_PROJECT="bson-ruby"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A Ruby BSON implementation for MongoDB. (Includes binary C-based extension.)"
+HOMEPAGE="http://www.mongodb.org/"
+SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="bson-ruby-${PV}"
+
+LICENSE="APSL-2"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE="test doc"
+
+all_ruby_prepare() {
+ # Remove bundler support
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+
+ # Remove project-specific rspec options
+ rm .rspec || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext/bson extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake -C ext/bson V=1 CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
+ cp ext/bson/*$(get_modname) lib/ || die
+}