summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-12-27 21:32:11 +0100
committerHans de Graaff <graaff@gentoo.org>2023-12-27 21:32:11 +0100
commit2f2eb84a8ba6dfc9faabd434ccf49b1d2fe9c379 (patch)
treee77305e49f649ec501f4305c2edc37f192cf36bb /dev-ruby/connection_pool
parentdev-ruby/countdownlatch: enable ruby33 (diff)
downloadgentoo-2f2eb84a8ba6dfc9faabd434ccf49b1d2fe9c379.tar.gz
gentoo-2f2eb84a8ba6dfc9faabd434ccf49b1d2fe9c379.tar.bz2
gentoo-2f2eb84a8ba6dfc9faabd434ccf49b1d2fe9c379.zip
dev-ruby/connection_pool: drop 2.3.0, 2.4.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/connection_pool')
-rw-r--r--dev-ruby/connection_pool/Manifest2
-rw-r--r--dev-ruby/connection_pool/connection_pool-2.3.0.ebuild29
-rw-r--r--dev-ruby/connection_pool/connection_pool-2.4.0.ebuild29
3 files changed, 0 insertions, 60 deletions
diff --git a/dev-ruby/connection_pool/Manifest b/dev-ruby/connection_pool/Manifest
index 9bee1cb9a6be..b6511dbbfed6 100644
--- a/dev-ruby/connection_pool/Manifest
+++ b/dev-ruby/connection_pool/Manifest
@@ -1,3 +1 @@
-DIST connection_pool-2.3.0.tar.gz 10656 BLAKE2B 235ddcf6956c53bff276c27b47f3dd21f008cad4eea07692cad186117e6d6a986acb1fa1e2eeb29a9bb72f5ee5e3b7c80927e711ebdf00ceec9af2f02ca37e25 SHA512 8f9c9c1c738b5321b52c28033bb7ac8f6697edfe584f858ce4891514c65730ccb950db9136f059991c4fe1d1386b18883d7b61557aeeb687c602a09229dcb38f
-DIST connection_pool-2.4.0.tar.gz 11243 BLAKE2B b8fcb164473863dfa4d4cd0a2f511f006ab0369a3890639115b42755eb6a50f1e8e37e1b2bdba0a4ac203ef05e5fde84cc95b0f10f547b56effbaa19df0ee64e SHA512 7b3d732da657ecdd1ebe2fa1600c0d723496be9c89397db3da06d854daba07aa959750527ec2c08bdf5a41e30df2ee04407fe76260440848db9b426c508a3544
DIST connection_pool-2.4.1.tar.gz 11425 BLAKE2B 17aae4f8ce0461554eaddb4ee3535062608d75a29219ca44b1535f087db39429ddbc591d996c020b1fa557337e75bb15b0ac218e8b9f393f94e32e70ffe76800 SHA512 4529446de89d01adee28127807fe104ada683866bc61b60ee77acb718881aced982aa1a1e6e2330077d79ed3d77af199e8612a6dc08de4c40468ac4e3623b799
diff --git a/dev-ruby/connection_pool/connection_pool-2.3.0.ebuild b/dev-ruby/connection_pool/connection_pool-2.3.0.ebuild
deleted file mode 100644
index 93e7f57f0e54..000000000000
--- a/dev-ruby/connection_pool/connection_pool-2.3.0.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31 ruby32"
-
-RUBY_FAKEGEM_GEMSPEC="connection_pool.gemspec"
-RUBY_FAKEGEM_RECIPE_TEST="rake"
-RUBY_FAKEGEM_RECIPE_DOC="none"
-RUBY_FAKEGEM_EXTRADOC="Changes.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Generic connection pooling for Ruby"
-HOMEPAGE="https://github.com/mperham/connection_pool"
-SRC_URI="https://github.com/mperham/connection_pool/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~s390 ~sparc x86"
-IUSE=""
-
-ruby_add_bdepend "test? ( >=dev-ruby/minitest-5 )"
-
-all_ruby_prepare() {
- sed -i -e '/git ls-files/d' connection_pool.gemspec || die
- sed -i -e '/\(bundler\|standard\)/ s:^:#:' Rakefile || die
- sed -i -e "s/gem 'minitest'/gem 'minitest', '~> 5.0'/" test/helper.rb || die
-}
diff --git a/dev-ruby/connection_pool/connection_pool-2.4.0.ebuild b/dev-ruby/connection_pool/connection_pool-2.4.0.ebuild
deleted file mode 100644
index 93e7f57f0e54..000000000000
--- a/dev-ruby/connection_pool/connection_pool-2.4.0.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31 ruby32"
-
-RUBY_FAKEGEM_GEMSPEC="connection_pool.gemspec"
-RUBY_FAKEGEM_RECIPE_TEST="rake"
-RUBY_FAKEGEM_RECIPE_DOC="none"
-RUBY_FAKEGEM_EXTRADOC="Changes.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Generic connection pooling for Ruby"
-HOMEPAGE="https://github.com/mperham/connection_pool"
-SRC_URI="https://github.com/mperham/connection_pool/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~s390 ~sparc x86"
-IUSE=""
-
-ruby_add_bdepend "test? ( >=dev-ruby/minitest-5 )"
-
-all_ruby_prepare() {
- sed -i -e '/git ls-files/d' connection_pool.gemspec || die
- sed -i -e '/\(bundler\|standard\)/ s:^:#:' Rakefile || die
- sed -i -e "s/gem 'minitest'/gem 'minitest', '~> 5.0'/" test/helper.rb || die
-}