summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-06 07:19:33 +0100
committerSam James <sam@gentoo.org>2023-04-07 03:47:51 +0100
commit121ca60bac743912c83b65b1933de6ab65880583 (patch)
tree082f9753f4f9b30860f2ff737608126adc243430 /dev-ruby/minitest/minitest-5.15.0-r1.ebuild
parentdev-ruby/minitest: drop 5.14.4 (diff)
downloadgentoo-121ca60bac743912c83b65b1933de6ab65880583.tar.gz
gentoo-121ca60bac743912c83b65b1933de6ab65880583.tar.bz2
gentoo-121ca60bac743912c83b65b1933de6ab65880583.zip
dev-ruby/minitest: shift 5.15.0 into SLOT="5.15"
Needed because ruby32 depends on >=minitest-5.16 (it's bundled) but Rails still needs <minitest-5.16 and fixing that is far too invasive (doable, but a lot of work). Newer versions will remain in SLOT="5". Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby/minitest/minitest-5.15.0-r1.ebuild')
-rw-r--r--dev-ruby/minitest/minitest-5.15.0-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/minitest/minitest-5.15.0-r1.ebuild b/dev-ruby/minitest/minitest-5.15.0-r1.ebuild
new file mode 100644
index 000000000000..b28c97ca07f7
--- /dev/null
+++ b/dev-ruby/minitest/minitest-5.15.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="minitest/unit is a small and fast replacement for ruby's huge and slow test/unit"
+HOMEPAGE="https://github.com/seattlerb/minitest"
+
+LICENSE="MIT"
+SLOT="5.15"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+RDEPEND="!~dev-ruby/minitest-5.15.0:5"
+
+each_ruby_test() {
+ MT_NO_PLUGINS=true ${RUBY} -Ilib:test:. -e "Dir['**/test_*.rb'].each{|f| require f}" || die "Tests failed"
+}