summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-11-24 14:54:16 +0100
committerHans de Graaff <graaff@gentoo.org>2024-11-24 14:55:52 +0100
commit4ebacc86158fcd6c0007511a073a16f209253ff0 (patch)
tree17be6a5d1194a2cdd6bb0fa737eeb3e37a42fe58 /dev-ruby/oauth2
parentdev-lang/php: drop 8.2.25, 8.3.13 (diff)
downloadgentoo-4ebacc86158fcd6c0007511a073a16f209253ff0.tar.gz
gentoo-4ebacc86158fcd6c0007511a073a16f209253ff0.tar.bz2
gentoo-4ebacc86158fcd6c0007511a073a16f209253ff0.zip
dev-ruby/oauth2: add 2.0.9
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/oauth2')
-rw-r--r--dev-ruby/oauth2/Manifest1
-rw-r--r--dev-ruby/oauth2/oauth2-2.0.9.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-ruby/oauth2/Manifest b/dev-ruby/oauth2/Manifest
index 0226b5624afc..68203bd5a753 100644
--- a/dev-ruby/oauth2/Manifest
+++ b/dev-ruby/oauth2/Manifest
@@ -1 +1,2 @@
DIST oauth2-1.4.11.tar.bz2 65622 BLAKE2B 9a09e69eb2389289d5b048388dd52dd6edcf289c4d7262ead05cca7dd27b261b6f432e023ac3c34aa77d6fa33bca5d870726b96cf5bf85eeec3561e9b53f9501 SHA512 12a9133cd5813eed00c2a22995630a7fdb611b0d76b06eeb8c938fd826831ea37556822246f21a739ba427c74135e6c2046edc1fb008725c55f3b1000ab5a945
+DIST oauth2-2.0.9.tar.bz2 86459 BLAKE2B ba5623cf81824468489d68a4a06d1677ae05931e92471ea5c536292e5f688f4208915552a1cced22b66906149fe5c12a6da4ab6cc4a724ad3fce721b828a4f1e SHA512 d5d80bb3f34daf63d1723791d158abbaa53fbb9a1d85401267079762066c4fb031ef7ab7d259cdb7b351024ff5a35a22a55080dadc44d52dd32515df1ebfbce6
diff --git a/dev-ruby/oauth2/oauth2-2.0.9.ebuild b/dev-ruby/oauth2/oauth2-2.0.9.ebuild
new file mode 100644
index 000000000000..f6dad2a18743
--- /dev/null
+++ b/dev-ruby/oauth2/oauth2-2.0.9.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="oauth2.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Wrapper for the OAuth 2.0 protocol with a similar style to the OAuth gem"
+HOMEPAGE="https://gitlab.com/oauth-xx/oauth2"
+SRC_URI="https://gitlab.com/oauth-xx/oauth2/-/archive/v${PV}/oauth2-${PV}.tar.bz2"
+RUBY_S="oauth2-v${PV}-*"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+ruby_add_rdepend "
+ || ( dev-ruby/faraday:2 dev-ruby/faraday:1 )
+ dev-ruby/jwt:2
+ >=dev-ruby/multi_xml-0.5:0
+ >=dev-ruby/rack-1.2:* <dev-ruby/rack-4:*
+ dev-ruby/snaky_hash:1
+ >=dev-ruby/version_gem-1.1:1
+"
+ruby_add_bdepend "test? (
+ >=dev-ruby/addressable-2.3
+ >=dev-ruby/backports-3
+ >=dev-ruby/rexml-3.2:3
+ dev-ruby/rspec:3
+ dev-ruby/rspec-pending_for
+ dev-ruby/rspec-stubbed_env
+)"
+
+all_ruby_prepare() {
+ sed \
+ -e '/silent/I s:^:#:' \
+ -e '/require.*oauth2/arequire "oauth2/version"' \
+ -i spec/spec_helper.rb || die
+
+ sed -i -e '/yardstick/,/^end/ s:^:#:' \
+ -e '/bundler/I s:^:#:' Rakefile || die
+
+ # Avoid spec that is too fragile in relation to ENV
+ sed -i -e '/outputs to $stdout when OAUTH_DEBUG=true/a skip "fragile ENV stubbing"' spec/oauth2/client_spec.rb || die
+
+ # Avoid specs depending on unpackaged silent_stream gem
+ sed -e '/with warning for \(no\|too many\) token/ s/context/xcontext/' \
+ -e '/with keys in a different order to the lookup/ s/context/xcontext/' \
+ -i spec/oauth2/access_token_spec.rb || die
+ sed -e '/when OAUTH_DEBUG=\(false\|true\)/ s/context/xcontext/' \
+ -e '/with extract_access_token option/ s/describe/xdescribe/' \
+ -i spec/oauth2/client_spec.rb || die
+
+ # Avoid specs failing due to differences in errors in newer versions
+ # of dependencies.
+ sed -e '/when parse: :xml but response is JSON/ s/context/xcontext/' \
+ -i spec/oauth2/client_spec.rb || die
+ sed -e '/with bad encoding params/ s/context/xcontext/' \
+ -i spec/oauth2/strategy/assertion_spec.rb || die
+
+ sed -e 's/git ls-files -z/find * -print0/' \
+ -e "s:_relative ': './:" \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ CI=true ${RUBY} -S rspec-3 --format progress spec || die
+}