summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-11-07 07:17:59 +0100
committerHans de Graaff <graaff@gentoo.org>2016-11-07 07:18:43 +0100
commit61c943b8615ce67cbaee4d6a492ae1a0746cf0ce (patch)
tree000f65f812dfa96f321086cf495cb0b5350b7856 /dev-ruby/shoulda-context
parentdev-ruby/public_suffix: add 2.0.4 (diff)
downloadgentoo-61c943b8615ce67cbaee4d6a492ae1a0746cf0ce.tar.gz
gentoo-61c943b8615ce67cbaee4d6a492ae1a0746cf0ce.tar.bz2
gentoo-61c943b8615ce67cbaee4d6a492ae1a0746cf0ce.zip
dev-ruby/shoulda-context: add 1.2.2
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby/shoulda-context')
-rw-r--r--dev-ruby/shoulda-context/Manifest1
-rw-r--r--dev-ruby/shoulda-context/shoulda-context-1.2.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/shoulda-context/Manifest b/dev-ruby/shoulda-context/Manifest
index 1ad1f7486941..6b55f0f314af 100644
--- a/dev-ruby/shoulda-context/Manifest
+++ b/dev-ruby/shoulda-context/Manifest
@@ -1 +1,2 @@
DIST shoulda-context-1.2.1.gem 24064 SHA256 a52c1ce8aeb868af7a1f98d63f748bfdea353f98bce35181ed2bffa266149b1b SHA512 eda6f82c101d0abdf517cabd9663a6a45d9e3d1ef19bdc51d4de35a45e18de15b1aee02a7a557460a3a9b1eafa61cd892240563b6f239b94339e9869c6e63ef3 WHIRLPOOL 9a5fa8ab2e8f1511512ea82ca7d4883157174f10c2b40a76f8020839cfa946964249acd5540b8582f269952574a32866d03a463520176ddf9e1671668b1999af
+DIST shoulda-context-1.2.2.gem 24064 SHA256 6c25ac1938b9009807c37c2e497fac84f768db3c89d67688459a2ce6bb6616d0 SHA512 b09f5ce2db59bbb26d5678b17b6641b79df7983d25e81a31bc10c42b702bdba09795b692d711d59c103beb2f691b503567e37c46668f77e600416551ef2c5e05 WHIRLPOOL 0fa227622d36d504ad62e347d735239974706644135e97a662476961d3f1420248d6a78207a125b1623be6cbee3396b2507682f0dc8b099ace919bacb9d3df7f
diff --git a/dev-ruby/shoulda-context/shoulda-context-1.2.2.ebuild b/dev-ruby/shoulda-context/shoulda-context-1.2.2.ebuild
new file mode 100644
index 000000000000..af8021b3429b
--- /dev/null
+++ b/dev-ruby/shoulda-context/shoulda-context-1.2.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING.md README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb rails tasks"
+
+# Don't install the conversion script to avoid collisions with older
+# shoulda.
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Context framework extracted from Shoulda"
+HOMEPAGE="http://thoughtbot.com/projects/shoulda"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64"
+IUSE="doc test"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2
+ <dev-ruby/mocha-1 )"
+
+all_ruby_prepare() {
+ sed -i -e "1igem 'mocha', '~>0.10'\n" test/test_helper.rb || die
+}
+
+each_ruby_test() {
+ BUNDLE_GEMFILE=x ruby-ng_testrb-2 -Itest test/shoulda/*_test.rb || die
+}