summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-08-09 07:19:50 +0200
committerHans de Graaff <graaff@gentoo.org>2016-08-09 07:19:50 +0200
commit2455d25203dbc4693fcb0751a0711f252f51145a (patch)
tree1491ad0f8b13c9e37a0361604b50622276298d37 /dev-ruby/syntax/syntax-1.2.1.ebuild
parentdev-ruby/rspec-retry: add 0.5.0 (diff)
downloadgentoo-2455d25203dbc4693fcb0751a0711f252f51145a.tar.gz
gentoo-2455d25203dbc4693fcb0751a0711f252f51145a.tar.bz2
gentoo-2455d25203dbc4693fcb0751a0711f252f51145a.zip
dev-ruby/syntax: add 1.2.1
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/syntax/syntax-1.2.1.ebuild')
-rw-r--r--dev-ruby/syntax/syntax-1.2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/syntax/syntax-1.2.1.ebuild b/dev-ruby/syntax/syntax-1.2.1.ebuild
new file mode 100644
index 000000000000..11b580b5785c
--- /dev/null
+++ b/dev-ruby/syntax/syntax-1.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Syntax highlighting for sourcecode and HTML"
+HOMEPAGE="https://github.com/dblock/syntax"
+SRC_URI="https://github.com/dblock/syntax/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test doc"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
+
+all_ruby_prepare() {
+ # Remove manual doc since it can not longer be build and it blocks default rdoc recipe.
+ rm -rf doc || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/ALL-TESTS.rb || die
+}