summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-03-20 10:09:25 +0100
committerHans de Graaff <graaff@gentoo.org>2022-03-20 11:04:35 +0100
commitc4fccbbe805edaf53d753f18d20c8f341b930598 (patch)
treebe0ed74e8f5ebd092da4e271f8c6ac8810437598 /dev-ruby/temple
parentdev-ruby/erubis: add ruby31 (diff)
downloadgentoo-c4fccbbe805edaf53d753f18d20c8f341b930598.tar.gz
gentoo-c4fccbbe805edaf53d753f18d20c8f341b930598.tar.bz2
gentoo-c4fccbbe805edaf53d753f18d20c8f341b930598.zip
dev-ruby/temple: add ruby30; EAPI 8
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/temple')
-rw-r--r--dev-ruby/temple/temple-0.8.2-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/temple/temple-0.8.2-r1.ebuild b/dev-ruby/temple/temple-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..9a7616a68d2b
--- /dev/null
+++ b/dev-ruby/temple/temple-0.8.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES EXPRESSIONS.md README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="An abstraction and a framework for compiling templates to pure Ruby"
+HOMEPAGE="https://github.com/judofyr/temple"
+
+LICENSE="MIT"
+SLOT="0.7"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/bacon
+ dev-ruby/erubis
+ >=dev-ruby/tilt-2.0.1 )"
+
+each_ruby_test() {
+ ${RUBY} -S bacon -Ilib -Itest --automatic --quiet || die
+}