summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-11-03 08:23:49 +0100
committerHans de Graaff <graaff@gentoo.org>2024-11-03 08:23:49 +0100
commit0d8407cc4575d4940c679aea94dab1b6911df384 (patch)
treef84e4788cd79ec9375079af4903591726d279a00 /dev-ruby
parentdev-ruby/ruby-gettext: drop 3.4.6 (diff)
downloadgentoo-0d8407cc4575d4940c679aea94dab1b6911df384.tar.gz
gentoo-0d8407cc4575d4940c679aea94dab1b6911df384.tar.bz2
gentoo-0d8407cc4575d4940c679aea94dab1b6911df384.zip
dev-ruby/ruby-filemagic: enable ruby33
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-filemagic/ruby-filemagic-0.7.3.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-ruby/ruby-filemagic/ruby-filemagic-0.7.3.ebuild b/dev-ruby/ruby-filemagic/ruby-filemagic-0.7.3.ebuild
index 7ed5b5610070..b23d8012a069 100644
--- a/dev-ruby/ruby-filemagic/ruby-filemagic-0.7.3.ebuild
+++ b/dev-ruby/ruby-filemagic/ruby-filemagic-0.7.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby30 ruby31 ruby32"
+USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="ChangeLog README TODO"
@@ -20,7 +20,7 @@ HOMEPAGE="https://github.com/blackwinter/ruby-filemagic"
LICENSE="Ruby-BSD"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
+IUSE="test"
DEPEND="${DEPEND} sys-apps/file test? ( >=sys-apps/file-5.30 )"
RDEPEND="${RDEPEND} sys-apps/file"
@@ -32,7 +32,8 @@ all_ruby_prepare() {
file -C -m perl || die
popd || die
- sed -i -e '/test_check_compiled/aomit "different result with file 5.41"' test/filemagic_test.rb || die
+ sed -e '/test_\(abbrev_mime_type\|check_compiled\|singleton\)/aomit "different result with file 5.41"' \
+ -i test/filemagic_test.rb || die
}
each_ruby_test() {