summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-10-18 07:24:11 +0200
committerHans de Graaff <graaff@gentoo.org>2023-10-18 14:20:01 +0200
commit114799b82cbd179e409f0e5632549ee63351846b (patch)
tree2644a2bf930ca0410f5549d2a75bf328d9a607ac /dev-ruby
parentwebapp.eclass: optimize webapp_serverowned() and inline webapp_strip_*() (diff)
downloadgentoo-114799b82cbd179e409f0e5632549ee63351846b.tar.gz
gentoo-114799b82cbd179e409f0e5632549ee63351846b.tar.bz2
gentoo-114799b82cbd179e409f0e5632549ee63351846b.zip
dev-ruby/capistrano: add 3.18.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/capistrano/Manifest1
-rw-r--r--dev-ruby/capistrano/capistrano-3.18.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/capistrano/Manifest b/dev-ruby/capistrano/Manifest
index 12ad40673080..e410257ca6c5 100644
--- a/dev-ruby/capistrano/Manifest
+++ b/dev-ruby/capistrano/Manifest
@@ -1,2 +1,3 @@
DIST capistrano-2.15.5.gem 132096 BLAKE2B bbaa6bd482cf9bbe7aa01540aa5dab3f32401ffa1476d9057bb8ad420194f1ab2c32d8e744d7c982ebece5c4b5369133dc8378b7adf54c78732f9cb249db2a9e SHA512 10168080c7481ec6fc6f918ac90a3b1ce8f2b36f77411375e33cc915b02d5196ab061ac47e767edd724c82cffd1c2ad0a23ba1f0519cf1f2aae5b429167b19ff
DIST capistrano-3.17.3.gem 70144 BLAKE2B d8bd93bb41a41196394b0959fa0bdf17609c9c53771bbfbf87cbc02b169177ad7cc18613a18d362a7fc775c91a382071d2384262d5cb49b1534678aac575dc55 SHA512 b7b85ebf7309d93aed83f68dc897e5a6cb4c8a929f4427c8a29db2ef6f857ee110256ba80c2fe0ae15f8008597c47be5ec60c192f3268d0df66f761b90d0758f
+DIST capistrano-3.18.0.gem 69632 BLAKE2B 679005f347eba2bad71e49b0c591c6179edc566d342b43652dc1be6949589d3bc58b78c91cccc564e6d8bb1f541066917164e000fe41a6997a3d6d12ab9b5e7b SHA512 126abb8934bed1bd1c58f53c1e8cd0ead99499d7e99d09e51290df4619a2f570a3f2f1a5cbdb683f1286a2b9aa7b0a2690a4c165d07705c5157ebf3ed1118f3e
diff --git a/dev-ruby/capistrano/capistrano-3.18.0.ebuild b/dev-ruby/capistrano/capistrano-3.18.0.ebuild
new file mode 100644
index 000000000000..e8af537d4759
--- /dev/null
+++ b/dev-ruby/capistrano/capistrano-3.18.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A distributed application deployment system"
+HOMEPAGE="https://capistranorb.com/"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/airbrussh-1.0.0
+ >=dev-ruby/sshkit-1.9:0
+ >=dev-ruby/rake-10.0.0
+ dev-ruby/i18n:*"
+ruby_add_bdepend "
+ test? ( dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ # Avoid specs that depend on capistrano already being installed
+ rm -f spec/lib/capistrano/doctor/gems_doctor_spec.rb || die
+
+ # Avoid specs that require a TTY
+ sed -i -e '/asking for a variable/,/^ end/ s:^:#:' spec/integration/dsl_spec.rb || die
+ rm -f spec/lib/capistrano/configuration/question_spec.rb spec/lib/capistrano/doctor/output_helpers_spec.rb || die
+}