summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-12-05 08:08:16 +0100
committerHans de Graaff <graaff@gentoo.org>2024-12-05 11:08:18 +0100
commit89a2952f89fbca5c979996bca3539a41c27cdc3e (patch)
tree0d6ecc85b9b79065473b1ed7a070b0bbd9fa9937 /dev-ruby
parentdev-ruby/json: add 2.9.0 (diff)
downloadgentoo-89a2952f89fbca5c979996bca3539a41c27cdc3e.tar.gz
gentoo-89a2952f89fbca5c979996bca3539a41c27cdc3e.tar.bz2
gentoo-89a2952f89fbca5c979996bca3539a41c27cdc3e.zip
dev-ruby/net-http-persistent: add 4.0.5
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/net-http-persistent/Manifest1
-rw-r--r--dev-ruby/net-http-persistent/net-http-persistent-4.0.5.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/net-http-persistent/Manifest b/dev-ruby/net-http-persistent/Manifest
index 3ad6bec430d2..9f7f0ed3b29b 100644
--- a/dev-ruby/net-http-persistent/Manifest
+++ b/dev-ruby/net-http-persistent/Manifest
@@ -1,2 +1,3 @@
DIST net-http-persistent-4.0.2.tar.gz 23779 BLAKE2B 7ea0140ed9baf97f05f13816ddd836cc874a1861a0ca4d84d98fd8d5665163e96d74c6eef602088a12577addda8fad5c2194c7f679c59917255979c5618c1c8d SHA512 4ef028245092a15f5e017ed6f2723cb82a2ed1fdbcb55217e5807068a40601151c29f929c95ffb5bdaae12fe34dca6658e674e282be42e7b0909c0ff2ea984fd
DIST net-http-persistent-4.0.4.tar.gz 24093 BLAKE2B 9470b3638dd5c4fcf5af93c7341c73e10c7e70a4a86e20e6f425a3449fcb0b5950adb4579cb12926e64556f03eaf3c3aaf3969694dd8bbc82d6d9dc59077c4a7 SHA512 43e51d6803d381af6a203508484c7bd39356d277818541fd192c0c539d4ec9e2088414b199f99b174def59e1818b9bf34d1d205d4137c9529fc7409d6813a986
+DIST net-http-persistent-4.0.5.tar.gz 24367 BLAKE2B 724f72ed14198493c1b044157cb233010bab470be6915998eb19c32ced5f701e86f2534fefea088d3f46ea0acd4b07c1c5e3b8e6d191a006a97d012a4b6adca7 SHA512 79aea45a34631935de65d21db2b7f8832f60a107e70d40cd6d52b4a0fe5c4790222c8aa673b677b4c9a5c58e5d1718c95c81a33866b35c390d49d41854361d05
diff --git a/dev-ruby/net-http-persistent/net-http-persistent-4.0.5.ebuild b/dev-ruby/net-http-persistent/net-http-persistent-4.0.5.ebuild
new file mode 100644
index 000000000000..cdc184338ddc
--- /dev/null
+++ b/dev-ruby/net-http-persistent/net-http-persistent-4.0.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Manages persistent connections using Net::HTTP plus a speed fix for Ruby 1.8"
+HOMEPAGE="https://github.com/drbrain/net-http-persistent"
+SRC_URI="https://github.com/drbrain/net-http-persistent/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc test"
+
+ruby_add_rdepend ">=dev-ruby/connection_pool-2.2:0"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ # Not relevant for us (we're just using rake for the tests)
+ sed -i -e '/require "rake\/manifest"/,/^end/ s:^:#:' Rakefile || die
+
+ # avoid test with implicit dependency on net-http-pipeline which
+ # fails and is not tested upstream
+ sed -i -e '/net-http-pipeline not installed/ s/unless.*$//' test/test_net_http_persistent.rb || die
+}