summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabi Falk <gabifalk@gmx.com>2024-10-12 16:40:00 +0000
committerSam James <sam@gentoo.org>2024-12-01 12:37:02 +0000
commitbe34a2ecb62c1757d5f31d3534f8c897e6719a98 (patch)
treea1c79da95d62c0e705e1f5241afb999ffc2311c6 /dev-ruby
parentdev-ruby/io-event: 1.6.5: backport upstream commit to fix the testsuite (diff)
downloadgentoo-be34a2ecb62c1757d5f31d3534f8c897e6719a98.tar.gz
gentoo-be34a2ecb62c1757d5f31d3534f8c897e6719a98.tar.bz2
gentoo-be34a2ecb62c1757d5f31d3534f8c897e6719a98.zip
dev-ruby/io-event: 1.5.1: apply upstream commit to fix the testsuite
Link: https://github.com/socketry/io-event/commit/c2ffc28e97a08534e003eaf25abfa35279274263 Closes: https://bugs.gentoo.org/941411 Signed-off-by: Gabi Falk <gabifalk@gmx.com> Closes: https://github.com/gentoo/gentoo/pull/38956 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/io-event/io-event-1.5.1-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/io-event/io-event-1.5.1-r1.ebuild b/dev-ruby/io-event/io-event-1.5.1-r1.ebuild
new file mode 100644
index 000000000000..49f3e0ca5c6d
--- /dev/null
+++ b/dev-ruby/io-event/io-event-1.5.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
+RUBY_FAKEGEM_EXTRADOC="readme.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="sus"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An event loop"
+HOMEPAGE="https://github.com/socketry/io-event"
+SRC_URI="https://github.com/socketry/io-event/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+io-uring"
+
+RDEPEND="io-uring? ( sys-libs/liburing:= )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.5-update-test-hooks.patch
+)
+
+all_ruby_prepare() {
+ sed -i -E 's/require_relative "(.+)"/require File.expand_path("\1")/g' "${RUBY_FAKEGEM_GEMSPEC}" || die
+
+ # Avoid dependency on unpackaged covered package
+ rm -f config/sus.rb || die
+
+ if ! use io-uring ; then
+ sed -i -e "s:have_library('uring'):have_library('idonotexist_uring'):" ext/extconf.rb || die
+ fi
+}