summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-08-27 13:58:59 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-08-27 13:58:59 -0500
commitfc8bfd0eba2cc65bcc2fa58ce03a5da32a259277 (patch)
tree898cfc970d3378ab27cda74f6b53bcf38ea63c80 /dev-ruby
parentapp-admin/puppetdb: 6.12.0 bump (diff)
downloadgentoo-fc8bfd0eba2cc65bcc2fa58ce03a5da32a259277.tar.gz
gentoo-fc8bfd0eba2cc65bcc2fa58ce03a5da32a259277.tar.bz2
gentoo-fc8bfd0eba2cc65bcc2fa58ce03a5da32a259277.zip
dev-ruby/puppetdb-termini: 6.12.0 bump
Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/puppetdb-termini/Manifest1
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-6.12.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/Manifest b/dev-ruby/puppetdb-termini/Manifest
index 1d5f257172ae..608afb4faebb 100644
--- a/dev-ruby/puppetdb-termini/Manifest
+++ b/dev-ruby/puppetdb-termini/Manifest
@@ -1,2 +1,3 @@
DIST puppetdb-termini_6.10.0-1stretch_all.deb 21294 BLAKE2B dfe88c6a44eed3e8a0826fde8f6130d3d817acafa367415956587e44298c99c41fd7bdac709c1ab55dcc9dce165d2599a2f18f0e1fd058d717128c0dd3a6ae28 SHA512 da7bf41e43acc39a44655e4759a14c119e6c1665c01a8b0ad4d83767c65068e071fc8ff6af80810a20cf92508c55c9ccfa295e197c0f7c94ee70110ea4515aae
DIST puppetdb-termini_6.11.2-1stretch_all.deb 21292 BLAKE2B c708f816ff656b1a8720bc59c7498be26e233d6f7413ac181b0c0fe4c940aa5a059a62719a8b5edd8da355090a2c91353838e7d5c960af5a1195dd933eec9729 SHA512 548baf1c6a9be3f3d2dc3686e19851a36d1b10d123ce9c9aee1689f18b9ac8e15ed0300b766b5cde1c426689d41f23b2d72e8779f19cc82ff17c4b3006e68bcf
+DIST puppetdb-termini_6.12.0-1stretch_all.deb 21290 BLAKE2B 11bc0a316517190162e7e4e5a2ce05bc880ef8412bfcf5fb66ec68545bd7779e217d5d5e75ab79f24fc6b2f68e1a962262704efb8833fdce84288d060245b898 SHA512 a742825e9f9bacf5726814474b7812393d1a51c50fd710d771c10a9e23c874a465c6859fc17485b66a2c4114ac170f2f25c5ce1be6684ff18f5da31dc9ef0744
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-6.12.0.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-6.12.0.ebuild
new file mode 100644
index 000000000000..a7f2b53b2dde
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-6.12.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="http://docs.puppetlabs.com/puppetdb/"
+SRC_URI="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}