summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-02-27 08:24:22 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-02-27 08:24:22 +0100
commite608ff82938353a507a4876a5e4fd9d287960055 (patch)
tree950a9f189534128cabb8b19ffc163702646a1b6f /dev-tcltk/tkcon/tkcon-2.7.11.ebuild
parentdev-tcltk/thread: add 2.8.8 (diff)
downloadgentoo-e608ff82938353a507a4876a5e4fd9d287960055.tar.gz
gentoo-e608ff82938353a507a4876a5e4fd9d287960055.tar.bz2
gentoo-e608ff82938353a507a4876a5e4fd9d287960055.zip
dev-tcltk/tkcon: add 2.7.11, drop 2.5-r1 & 2.7.3
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-tcltk/tkcon/tkcon-2.7.11.ebuild')
-rw-r--r--dev-tcltk/tkcon/tkcon-2.7.11.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-tcltk/tkcon/tkcon-2.7.11.ebuild b/dev-tcltk/tkcon/tkcon-2.7.11.ebuild
new file mode 100644
index 000000000000..6ee739f1193b
--- /dev/null
+++ b/dev-tcltk/tkcon/tkcon-2.7.11.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Tk GUI console"
+HOMEPAGE="http://tkcon.sourceforge.net/"
+SRC_URI="https://github.com/wjoye/${PN}/archive/v${PV}.tar.gz ->
+ ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE="doc"
+
+DEPEND="dev-lang/tk:*"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ mv docs/changes.txt CHANGES
+}
+
+src_install() {
+ local tclver="$(echo 'puts $tcl_version' | tclsh)"
+ local instdir=/usr/$(get_libdir)/tcl${tclver}/${PN}$(ver_cut 1-2)
+ dodir ${instdir}
+ cp -pP pkgIndex.tcl tkcon.tcl "${D}"${instdir} || die
+ dodir /usr/bin
+ dosym ${instdir}/tkcon.tcl /usr/bin/tkcon
+ if use doc; then
+ HTML_DOCS=( docs/* )
+ fi
+ einstalldocs
+}