summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2024-04-11 23:17:12 +0200
committerSebastian Pipping <sping@gentoo.org>2024-04-11 23:17:12 +0200
commitce55c48a686ce6ac2e3806c2dddce0d526f2763e (patch)
treebcd3dba3f4fc056f812e04ab2956fe5529de7daf /dev-tex
parentdev-lang/php: skip doomed test in 8.2.15, too (diff)
downloadgentoo-ce55c48a686ce6ac2e3806c2dddce0d526f2763e.tar.gz
gentoo-ce55c48a686ce6ac2e3806c2dddce0d526f2763e.tar.bz2
gentoo-ce55c48a686ce6ac2e3806c2dddce0d526f2763e.zip
dev-tex/dot2tex: PEP 517 + Python 3.12
Closes: https://bugs.gentoo.org/909974 Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/dot2tex/dot2tex-2.11.3-r1.ebuild63
-rw-r--r--dev-tex/dot2tex/files/dot2tex-2.11.3-setup-py-script.patch24
2 files changed, 87 insertions, 0 deletions
diff --git a/dev-tex/dot2tex/dot2tex-2.11.3-r1.ebuild b/dev-tex/dot2tex/dot2tex-2.11.3-r1.ebuild
new file mode 100644
index 000000000000..85bf337ba030
--- /dev/null
+++ b/dev-tex/dot2tex/dot2tex-2.11.3-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Graphviz to LaTeX converter"
+HOMEPAGE="https://dot2tex.readthedocs.org/ https://github.com/xyz2tex/dot2tex"
+SRC_URI="https://github.com/xyz2tex/dot2tex/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="doc examples"
+
+DEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/pydot[${PYTHON_USEDEP}]
+ media-gfx/graphviz
+"
+BDEPEND="doc? ( dev-python/sphinx )"
+
+EPYTEST_DESELECT=(
+ # https://github.com/xyz2tex/dot2tex/issues/94
+ tests/test_dot2tex.py::MultipleStatements::test_semicolon
+)
+
+PATCHES=(
+ "${FILESDIR}"/${P}-setup-py-script.patch
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Syntax failures (old-style print)
+ # Looks fixed in master: https://github.com/xyz2tex/dot2tex/commit/38aeef9615f90fe347c5c45d514eaf00b116422b
+ rm -r "${S}"/tests/experimental || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc ; then
+ cd "${S}/docs"
+ emake html
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dodoc -r docs/_build/html
+ fi
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-tex/dot2tex/files/dot2tex-2.11.3-setup-py-script.patch b/dev-tex/dot2tex/files/dot2tex-2.11.3-setup-py-script.patch
new file mode 100644
index 000000000000..9bda03b5a484
--- /dev/null
+++ b/dev-tex/dot2tex/files/dot2tex-2.11.3-setup-py-script.patch
@@ -0,0 +1,24 @@
+From 7b4c3e2b62a0e988db06051976260faa3889377a Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Thu, 11 Apr 2024 23:11:15 +0200
+Subject: [PATCH] setup.py: Drop script "dot2tex" that collides with entrypoint
+
+---
+ setup.py | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index d107eed..9f50c7c 100644
+--- a/setup.py
++++ b/setup.py
+@@ -25,7 +25,6 @@ Graphviz_, a more LaTeX friendly look and feel. This is accomplished by:
+ author_email='kjellmf@gmail.com',
+ url="https://github.com/kjellmf/dot2tex",
+ py_modules=['dot2tex.dot2tex', 'dot2tex.dotparsing'],
+- scripts=['dot2tex/dot2tex'],
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Environment :: Console',
+--
+2.44.0
+