summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2024-12-17 08:51:04 -0800
committerPatrick McLean <chutzpah@gentoo.org>2024-12-17 08:51:04 -0800
commit6cd58daf91d4c5d184fdf2c0a49ce1502248dfbe (patch)
tree3da5330952c30cc719794e1549ccda8761809119 /dev-util/bcc
parentsys-apps/amdgpu_top: Add proper USE flags to libdrm dep (diff)
downloadgentoo-6cd58daf91d4c5d184fdf2c0a49ce1502248dfbe.tar.gz
gentoo-6cd58daf91d4c5d184fdf2c0a49ce1502248dfbe.tar.bz2
gentoo-6cd58daf91d4c5d184fdf2c0a49ce1502248dfbe.zip
dev-util/bcc: add 0.32.0
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-util/bcc')
-rw-r--r--dev-util/bcc/Manifest1
-rw-r--r--dev-util/bcc/bcc-0.32.0.ebuild208
2 files changed, 209 insertions, 0 deletions
diff --git a/dev-util/bcc/Manifest b/dev-util/bcc/Manifest
index 139806fc60e4..faa09e3ce75c 100644
--- a/dev-util/bcc/Manifest
+++ b/dev-util/bcc/Manifest
@@ -1,3 +1,4 @@
DIST bcc-0.29.1.tar.gz 6778304 BLAKE2B 23df483df59ef7d66117b15628299a32155136aa5254edbf76f7507a972f3ebcba1d4b2aa83c41e8f061eeeb96812f522c34fed27e9a37e5f4ad3478c7cde88f SHA512 9e60130ea602e19e6c6f88a8c17023cea5daf4c5bcc7af8816e9f5c662341136eb449a3fdf870ffad215495ac3bf895115c0d968d92ce79ebe2899b3e2464d24
DIST bcc-0.30.0.tar.gz 6797246 BLAKE2B 517f4fcce8bcaf4c8c17075f9a906b452ee14a0c46fa500c301521fe46d854fcf4f632e741b34168dfeb819d9b0d64b967e716fa6222ba7dcaeddb03570985e6 SHA512 70478ca8c18e7f106c462513ca9af46f49b4ebcca6380a9393208fca88f83895a7396f918bf5d01dce1bc4a876bccb9b95aa56d426e55d384cf11c9baaa6a89b
DIST bcc-0.31.0.tar.gz 6807504 BLAKE2B 75739914a18a7952bbefbed6f55b88d3be4f0483d2fd74bf7d6f7a6491d659ab893e7bd6b5e74c7b2239d6a2a9db04522487e3b36e7ddf65b1cc2d8712f786a8 SHA512 a1fe855c316d0508814dc02382b13897ff565bee52de0fc9d7521eabd304227e41bf7d322b10ab29fd5b13aeac85cc75ee76ac348cf1f4bb6499b8853bac10ab
+DIST bcc-0.32.0.tar.gz 6812595 BLAKE2B 8ff131fc5e15eac3432f26c6b0846f5b1686acbfaaaf4758ab2698cdc51857e33fcf2009aea9a2ec06986476c4938d534467ab3905f3c7a74dbe713515181a9f SHA512 3612580976f9c91a52c49bc83abdbaccc9a066c30a7f178997cb91910307e48743d831ec028e0099e776250770b55e8fc8c937bcc9b1e36fbec88370376d1df4
diff --git a/dev-util/bcc/bcc-0.32.0.ebuild b/dev-util/bcc/bcc-0.32.0.ebuild
new file mode 100644
index 000000000000..0193f9da4405
--- /dev/null
+++ b/dev-util/bcc/bcc-0.32.0.ebuild
@@ -0,0 +1,208 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( luajit )
+DISTUTILS_OPTIONAL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{{10..13},13t} )
+LLVM_COMPAT=( {15..18} )
+
+inherit cmake linux-info llvm-r1 lua-single distutils-r1 toolchain-funcs
+
+DESCRIPTION="Tools for BPF-based Linux IO analysis, networking, monitoring, and more"
+HOMEPAGE="https://iovisor.github.io/bcc/"
+SRC_URI="https://github.com/iovisor/bcc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="+lua lzma +python static-libs test"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ lua? ( python ${LUA_REQUIRED_USE} )
+"
+
+# tests need root access
+RESTRICT="test"
+
+RDEPEND="
+ app-arch/zstd:=
+ >=dev-libs/elfutils-0.166:=
+ >=dev-libs/libbpf-1.2.0:=
+ dev-libs/libffi:=
+ sys-kernel/linux-headers
+ sys-libs/ncurses:=[tinfo]
+ $(llvm_gen_dep '
+ llvm-core/clang:${LLVM_SLOT}=
+ llvm-core/llvm:${LLVM_SLOT}=
+ ')
+ lzma? ( || (
+ app-arch/xz-utils
+ app-arch/lzma
+ ) )
+ python? ( ${PYTHON_DEPS} )
+ lua? ( ${LUA_DEPS} )
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ || (
+ net-misc/iputils[arping]
+ net-analyzer/arping
+ )
+ net-analyzer/netperf
+ net-misc/iperf:*
+ )
+"
+BDEPEND="
+ app-arch/zip
+ sys-devel/flex
+ sys-devel/bison
+ virtual/pkgconfig
+ python? ( ${DISTUTILS_DEPS} )
+"
+
+PATCHES=(
+ "${FILESDIR}/bcc-0.9.0-no-luajit-automagic-dep.patch"
+ "${FILESDIR}/bcc-0.25.0-cmakelists.patch"
+ "${FILESDIR}/bcc-0.23.0-man-compress.patch"
+ "${FILESDIR}/bcc-0.31.0-no-automagic-deps.patch"
+)
+
+pkg_pretend() {
+ local CONFIG_CHECK="~BPF ~BPF_SYSCALL ~NET_CLS_BPF ~NET_ACT_BPF
+ ~HAVE_EBPF_JIT ~BPF_EVENTS ~DEBUG_INFO ~FUNCTION_TRACER ~KALLSYMS_ALL
+ ~KPROBES"
+
+ check_extra_config
+}
+
+pkg_setup() {
+ llvm-r1_pkg_setup
+ use python && python_setup
+}
+
+bcc_distutils_phase() {
+ if use python; then
+ local python_phase_func="distutils-r1_${EBUILD_PHASE_FUNC}"
+
+ if declare -f "${python_phase_func}" > /dev/null; then
+ pushd "${S}/src/python" > /dev/null || die
+ MY_S="${S}" S="${S}/src/python" "${python_phase_func}"
+ popd > /dev/null || die
+ else
+ die "Called ${FUNCNAME[0]} called in ${EBUILD_PHASE_FUNC}, but ${python_phase_func} doesn't exist"
+ fi
+ fi
+}
+
+src_prepare() {
+ local bpf_link_path
+
+ # this avoids bundling
+ bpf_link_path="$(realpath --relative-to="${S}/src/cc/libbpf" /usr/include/bpf)" || die
+ ln -sfn "${bpf_link_path}" src/cc/libbpf/include || die
+
+ # bug 811288
+ local script scriptname
+ for script in $(find tools/old -type f -name "*.py" || die); do
+ mv "${script}" "tools/old/old-${script##*/}" || die
+ done
+
+ sed -i '/#include <error.h>/d' examples/cpp/KModRetExample.cc || die
+
+ use static-libs || PATCHES+=( "${FILESDIR}/bcc-0.31.0-dont-install-static-libs.patch" )
+
+ # use distutils-r1 eclass funcs rather than letting upstream handle python
+ printf '\n' > src/python/CMakeLists.txt || die
+
+ if use python; then
+ for python_file in $(find "${S}/src/python" -name '*.py.in' || die); do
+ sed "s:@REVISION@:${PV%%_*}:" "${python_file}" > "${python_file%.in}" || die
+ done
+ fi
+
+ cmake_src_prepare
+ bcc_distutils_phase
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DREVISION=${PV%%_*}
+ -DENABLE_LLVM_SHARED=ON
+ -DENABLE_NO_PIE=OFF
+ -DWITH_LZMA=$(usex lzma)
+ -DCMAKE_USE_LIBBPF_PACKAGE=ON
+ -DLIBBPF_INCLUDE_DIRS="$($(tc-getPKG_CONFIG) --cflags-only-I libbpf | sed 's:-I::g')"
+ -DKERNEL_INCLUDE_DIRS="${KERNEL_DIR}"
+ -DNO_BLAZESYM=ON
+ -Wno-dev
+ )
+ if use lua && use lua_single_target_luajit; then
+ mycmakeargs+=( -DWITH_LUAJIT=ON )
+ fi
+
+ cmake_src_configure
+ bcc_distutils_phase
+}
+
+src_compile() {
+ cmake_src_compile
+ bcc_distutils_phase
+}
+
+bcc_tool_name() {
+ local -A rename_tools=(
+ [trace]=1
+ [profile]=1
+ [inject]=1
+ [capable]=1
+ )
+
+ local name="${1}"
+
+ local name="${name##*/}"
+ name="${name%.py}"
+
+ [[ -n ${rename_tools[${name}]} ]] && name=bcc-${name}
+
+ printf -- '%s\n' "${name}"
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ python_scriptinto /usr/sbin
+
+ local tool
+ for tool in $(grep -Elr '#!/usr/bin/(env |)python' "${MY_S}/tools"); do
+ python_newscript "${tool}" "$(bcc_tool_name "${tool}")"
+ done
+}
+
+src_install() {
+ cmake_src_install
+ bcc_distutils_phase
+
+ newenvd "${FILESDIR}"/60bcc.env 60bcc.env
+
+ local tool target
+ for tool in "${ED}"/usr/share/bcc/tools/*; do
+ [[ -d ${tool} || ! -x ${tool} || ${tool} =~ .*[.](c|txt) ]] && continue
+ grep -qE '^#!/usr/bin/(env |)python' "${tool}" && continue
+
+ target="/usr/sbin/$(bcc_tool_name "${tool}")"
+ [[ -e ${ED}${target} ]] && continue
+
+ dosym -r "${tool#${ED}}" "${target}"
+ done
+
+ docompress /usr/share/${PN}/man
+
+ newenvd - "70${P}" <<-_EOF_
+ MANPATH="${EPREFIX}/usr/share/${PN}/man"
+ _EOF_
+}