summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2024-11-08 12:35:06 +0100
committerAgostino Sarubbo <ago@gentoo.org>2024-11-08 12:35:06 +0100
commitdd68b1c24d4c4b8031324c3db1997abd7512c422 (patch)
treeeb4883ab59928fbb06eba4f985d86af52387674f /dev-util/bugbite-cli
parentx11-misc/xbindkeys: Stabilize 1.8.7-r100 ppc64, #942834 (diff)
downloadgentoo-dd68b1c24d4c4b8031324c3db1997abd7512c422.tar.gz
gentoo-dd68b1c24d4c4b8031324c3db1997abd7512c422.tar.bz2
gentoo-dd68b1c24d4c4b8031324c3db1997abd7512c422.zip
dev-util/bugbite-cli: version bump to 0.0.13 - add openssl backend
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'dev-util/bugbite-cli')
-rw-r--r--dev-util/bugbite-cli/Manifest1
-rw-r--r--dev-util/bugbite-cli/bugbite-cli-0.0.13.ebuild55
-rw-r--r--dev-util/bugbite-cli/metadata.xml3
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-util/bugbite-cli/Manifest b/dev-util/bugbite-cli/Manifest
index 162ef4c98893..1696bfaf76ff 100644
--- a/dev-util/bugbite-cli/Manifest
+++ b/dev-util/bugbite-cli/Manifest
@@ -1 +1,2 @@
DIST bugbite-cli-0.0.12.tar.xz 21202148 BLAKE2B dd7d7b0927741d77b3a724273360348558fc2675e22e948f2f9e2b418db6a263986e051ebb700094610e98021af6264288ebcbe271c0efac88c8091f9cd0725e SHA512 2056450d13ccbdf484ef2f4e4ea663a4f10fbd4222574e630510a85a0d10b2c939e9250be947b3bd1ea3a43a78f946b6e142db94f650aab0cd46db910f369411
+DIST bugbite-cli-0.0.13.tar.xz 22286212 BLAKE2B c906446a89ae2c7346318cffb96c93178585ef42589bba4df4ecdf906e8890a922324d484bbd252e119a8d47370c63816dfb0a55481586de6f30f13d7d3d84bc SHA512 40971032ff4e63416c3383a55418ba7c0c4c85321caace435000018da93176b6b1d83ee04aa4abdfa31646c9b6d1777c9e5acb035b14bca210bfc22ffc7fd90d
diff --git a/dev-util/bugbite-cli/bugbite-cli-0.0.13.ebuild b/dev-util/bugbite-cli/bugbite-cli-0.0.13.ebuild
new file mode 100644
index 000000000000..dacf74522b2c
--- /dev/null
+++ b/dev-util/bugbite-cli/bugbite-cli-0.0.13.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cargo edo shell-completion
+
+DESCRIPTION="A command line tool for bug, issue, and ticket mangling"
+HOMEPAGE="https://github.com/radhermit/bugbite"
+SRC_URI="https://github.com/radhermit/bugbite/releases/download/${P}/${P}.tar.xz"
+LICENSE="0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD BSD-2 Boost-1.0 CC0-1.0 ISC MIT MPL-2.0 Unicode-DFS-2016 Unlicense ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="openssl static test"
+RESTRICT="!test? ( test ) "
+
+BDEPEND="
+ >=virtual/rust-1.80
+ openssl? (
+ !static? ( dev-libs/openssl:= )
+ static? ( dev-libs/openssl:=[static-libs] )
+ )
+ test? ( dev-util/cargo-nextest )
+"
+
+QA_FLAGS_IGNORED="usr/bin/bite"
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]] && use static ; then
+ local rust_target=$( rustc -vV 2>/dev/null | sed -n 's|^host: ||p' )
+ [[ -z ${rust_target} ]] && die "Failed to read host target from rustc!"
+ export RUSTFLAGS="-C target-feature=+crt-static ${RUSTFLAGS}"
+ export static_stuff="--target ${rust_target}"
+ fi
+}
+
+src_configure() {
+ local myfeatures=(
+ $(usev openssl native-tls)
+ )
+ cargo_src_configure --no-default-features ${static_stuff}
+}
+
+src_test() {
+ edo cargo nextest run $(usev !debug '--release') --color always --features test --tests ${static_stuff}
+}
+
+src_install() {
+ cargo_src_install
+
+ doman man/*
+ dofishcomp shell/bite.fish
+ dozshcomp shell/_bite
+ newbashcomp shell/bite.bash bite
+}
diff --git a/dev-util/bugbite-cli/metadata.xml b/dev-util/bugbite-cli/metadata.xml
index e71a8c41c9c8..1b88e6c112b7 100644
--- a/dev-util/bugbite-cli/metadata.xml
+++ b/dev-util/bugbite-cli/metadata.xml
@@ -13,4 +13,7 @@
<upstream>
<remote-id type="github">radhermit/bugbite</remote-id>
</upstream>
+ <use>
+ <flag name="openssl">Use <pkg>dev-libs/openssl</pkg> as a crypto backend</flag>
+ </use>
</pkgmetadata>