summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-09-06 11:45:26 +0200
committerSam James <sam@gentoo.org>2020-09-16 01:42:40 +0000
commitaba688c9974e4ab03b6c3eb23ca69eb5cf15c587 (patch)
tree6c58e92644eea12f4b89aa7c1f74893b3e6789e7 /dev-util/cgdb/cgdb-9999.ebuild
parentdev-libs/girara: Version bump (v0.3.5) (diff)
downloadgentoo-aba688c9974e4ab03b6c3eb23ca69eb5cf15c587.tar.gz
gentoo-aba688c9974e4ab03b6c3eb23ca69eb5cf15c587.tar.bz2
gentoo-aba688c9974e4ab03b6c3eb23ca69eb5cf15c587.zip
dev-util/cgdb: respect AR, use eautoreconf for building
Eautoreconf ensures safe handling of the build scripts, so let's use that while setting AT_M4DIR to search for m4 files in the appropriate directory. Closes: https://bugs.gentoo.org/724256 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Closes: https://github.com/gentoo/gentoo/pull/17435 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/cgdb/cgdb-9999.ebuild')
-rw-r--r--dev-util/cgdb/cgdb-9999.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-util/cgdb/cgdb-9999.ebuild b/dev-util/cgdb/cgdb-9999.ebuild
index 403e3567898b..8750c546e4ca 100644
--- a/dev-util/cgdb/cgdb-9999.ebuild
+++ b/dev-util/cgdb/cgdb-9999.ebuild
@@ -12,7 +12,8 @@ else
SRC_URI="https://github.com/cgdb/cgdb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
fi
-inherit multilib-minimal
+inherit autotools multilib-minimal
+AT_M4DIR=config
DESCRIPTION="A curses front-end for GDB, the GNU debugger"
HOMEPAGE="https://cgdb.github.io/"
@@ -37,9 +38,15 @@ RDEPEND="
DOCS=( AUTHORS ChangeLog FAQ INSTALL NEWS README.md )
+PATCHES=(
+ # Bug: #724256
+ "${FILESDIR}/${PN}-0.7.1-respect-AR.patch"
+)
+
src_prepare() {
+ cp configure.{init,ac} || die "cp failed"
default
- ./autogen.sh || die
+ eautoreconf
}
multilib_src_test() {