summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-02 00:43:14 +0000
committerSam James <sam@gentoo.org>2021-01-02 00:43:14 +0000
commite212dbc6c4af0274dca590df5ee32219ebd424b0 (patch)
tree0d99e8bf001afa2cf168baf56f7c8351af0f1858 /dev-util/conf2struct/conf2struct-1.3-r1.ebuild
parentmedia-libs/libffado: revbump for libconfig subslot dep (diff)
downloadgentoo-e212dbc6c4af0274dca590df5ee32219ebd424b0.tar.gz
gentoo-e212dbc6c4af0274dca590df5ee32219ebd424b0.tar.bz2
gentoo-e212dbc6c4af0274dca590df5ee32219ebd424b0.zip
dev-util/conf2struct: revbump for libconfig subslot dep
Package-Manager: Portage-3.0.12-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/conf2struct/conf2struct-1.3-r1.ebuild')
-rw-r--r--dev-util/conf2struct/conf2struct-1.3-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/conf2struct/conf2struct-1.3-r1.ebuild b/dev-util/conf2struct/conf2struct-1.3-r1.ebuild
new file mode 100644
index 000000000000..c39a24cd4004
--- /dev/null
+++ b/dev-util/conf2struct/conf2struct-1.3-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic systemd toolchain-funcs
+
+DESCRIPTION="Create C parsers for libconfig and command-line"
+HOMEPAGE="https://github.com/yrutschle/conf2struct/"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/yrutschle/conf2struct.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~s390 ~x86"
+ SRC_URI="https://github.com/yrutschle/conf2struct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/libconfig:=
+ dev-perl/Conf-Libconfig"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" install
+}