summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2021-01-16 05:24:49 +0800
committerYixun Lan <dlan@gentoo.org>2021-01-16 05:28:20 +0800
commitc5877353626dffb6ae205ba420e59ef254b23bdc (patch)
tree8081d37f3bc1679898f77c00a9bedcc16569e226 /dev-util/crash/crash-9999.ebuild
parentdev-ml/markup: add dependency (diff)
downloadgentoo-c5877353626dffb6ae205ba420e59ef254b23bdc.tar.gz
gentoo-c5877353626dffb6ae205ba420e59ef254b23bdc.tar.bz2
gentoo-c5877353626dffb6ae205ba420e59ef254b23bdc.zip
dev-util/crash: version bump, 7.2.9
introduce a live ebuild also switch github source Closes: https://bugs.gentoo.org/761589 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-util/crash/crash-9999.ebuild')
-rw-r--r--dev-util/crash/crash-9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/crash/crash-9999.ebuild b/dev-util/crash/crash-9999.ebuild
new file mode 100644
index 000000000000..e807f3d302e0
--- /dev/null
+++ b/dev-util/crash/crash-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/crash-utility/crash.git"
+ SRC_URI="http://ftp.gnu.org/gnu/gdb/gdb-7.6.tar.gz"
+ EGIT_BRANCH="master"
+ KEYWORDS=""
+ inherit git-r3
+else
+ SRC_URI="https://github.com/crash-utility/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ mirror://gnu/gdb/gdb-7.6.tar.gz"
+ KEYWORDS="-* ~alpha ~amd64 ~arm ~ia64 ~ppc64 ~s390 ~x86"
+fi
+
+DESCRIPTION="Red Hat crash utility; used for analyzing kernel core dumps"
+HOMEPAGE="https://github.com/crash-utility/crash"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+# there is no "make test" target, but there is a test.c so the automatic
+# make rules catch it and tests fail
+RESTRICT="test"
+
+src_prepare() {
+ sed -i -e "s|ar -rs|\${AR} -rs|g" Makefile || die
+ ln -s "${DISTDIR}"/gdb-7.6.tar.gz . || die
+ default
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}