summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-01-05 15:49:30 -0500
committerAnthony G. Basile <blueness@gentoo.org>2017-01-05 15:49:50 -0500
commitd8f3f776a624a457259e6929c347693242a574f9 (patch)
treec1e85d26ca8e99815ed047e4ee2d8a9f48da1f5a /dev-util/gperf/gperf-3.1.ebuild
parentnet-analyzer/nagios-core: Add slot operator to perl dependency, bug 593788 (diff)
downloadgentoo-d8f3f776a624a457259e6929c347693242a574f9.tar.gz
gentoo-d8f3f776a624a457259e6929c347693242a574f9.tar.bz2
gentoo-d8f3f776a624a457259e6929c347693242a574f9.zip
dev-util/gperf: version bump to 3.1
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-util/gperf/gperf-3.1.ebuild')
-rw-r--r--dev-util/gperf/gperf-3.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/gperf/gperf-3.1.ebuild b/dev-util/gperf/gperf-3.1.ebuild
new file mode 100644
index 000000000000..f0e070bf08d1
--- /dev/null
+++ b/dev-util/gperf/gperf-3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DESCRIPTION="A perfect hash function generator"
+HOMEPAGE="https://www.gnu.org/software/gperf/"
+SRC_URI="mirror://gnu/gperf/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ sed -i \
+ -e "/^CPPFLAGS /s:=:+=:" \
+ */Makefile.in || die #444078
+
+ eapply_user
+}
+
+src_configure() {
+ econf --htmldir='$(datarootdir)/doc/'"${PF}/html"
+}