summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilfried Holzke <gentoo@holzke.net>2021-04-02 11:47:49 +0200
committerCraig Andrews <candrews@gentoo.org>2021-04-11 11:17:09 -0400
commitccb5830fe290c0fd8ae43546d188068cf4f60e91 (patch)
tree85418df6b45b4bf4b959e415acba59f42cf9cec3 /dev-util/hip/files/hip-4.1.0-DisableTest.patch
parentgames-util/xpadneo: drop 0.9 (diff)
downloadgentoo-ccb5830fe290c0fd8ae43546d188068cf4f60e91.tar.gz
gentoo-ccb5830fe290c0fd8ae43546d188068cf4f60e91.tar.bz2
gentoo-ccb5830fe290c0fd8ae43546d188068cf4f60e91.zip
dev-util/hip: Version bump to 4.1.0
Signed-off-by: Wilfried Holzke <gentoo@holzke.net> Package-Manager: Portage-3.0.17, Repoman-3.0.2 Closes: https://github.com/gentoo/gentoo/pull/20228 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-util/hip/files/hip-4.1.0-DisableTest.patch')
-rw-r--r--dev-util/hip/files/hip-4.1.0-DisableTest.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/hip/files/hip-4.1.0-DisableTest.patch b/dev-util/hip/files/hip-4.1.0-DisableTest.patch
new file mode 100644
index 000000000000..49e7171b2f0d
--- /dev/null
+++ b/dev-util/hip/files/hip-4.1.0-DisableTest.patch
@@ -0,0 +1,37 @@
+--- a/CMakeLists.txt 2021-03-28 18:02:34.755857717 +0200
++++ b/CMakeLists.txt 2021-03-28 18:04:54.217854203 +0200
+@@ -474,20 +474,20 @@
+ #############################
+ set(HIP_ROOT_DIR ${CMAKE_CURRENT_BINARY_DIR})
+ set(HIP_SRC_PATH ${CMAKE_CURRENT_SOURCE_DIR})
+-if(HIP_PLATFORM STREQUAL "nvidia")
+- execute_process(COMMAND "${CMAKE_COMMAND}" -E copy_directory "${HIP_SRC_PATH}/include" "${HIP_ROOT_DIR}/include" RESULT_VARIABLE RUN_HIT ERROR_QUIET)
+-endif()
+-execute_process(COMMAND "${CMAKE_COMMAND}" -E copy_directory "${HIP_SRC_PATH}/cmake" "${HIP_ROOT_DIR}/cmake" RESULT_VARIABLE RUN_HIT ERROR_QUIET)
+-if(${RUN_HIT} EQUAL 0)
+- execute_process(COMMAND "${CMAKE_COMMAND}" -E copy_directory "${HIP_SRC_PATH}/bin" "${HIP_ROOT_DIR}/bin" RESULT_VARIABLE RUN_HIT ERROR_QUIET)
+-endif()
+-if(${RUN_HIT} EQUAL 0)
+- set(CMAKE_MODULE_PATH "${HIP_ROOT_DIR}/cmake" ${CMAKE_MODULE_PATH})
+- include(${HIP_SRC_PATH}/tests/hit/HIT.cmake)
+- include(${HIP_SRC_PATH}/tests/Tests.cmake)
+-else()
+- message(STATUS "Testing targets will not be available. To enable them please ensure that the HIP installation directory is writeable. Use -DCMAKE_INSTALL_PREFIX to specify a suitable location")
+-endif()
++#if(HIP_PLATFORM STREQUAL "nvidia")
++# execute_process(COMMAND "${CMAKE_COMMAND}" -E copy_directory "${HIP_SRC_PATH}/include" "${HIP_ROOT_DIR}/include" RESULT_VARIABLE RUN_HIT ERROR_QUIET)
++#endif()
++#execute_process(COMMAND "${CMAKE_COMMAND}" -E copy_directory "${HIP_SRC_PATH}/cmake" "${HIP_ROOT_DIR}/cmake" RESULT_VARIABLE RUN_HIT ERROR_QUIET)
++#if(${RUN_HIT} EQUAL 0)
++# execute_process(COMMAND "${CMAKE_COMMAND}" -E copy_directory "${HIP_SRC_PATH}/bin" "${HIP_ROOT_DIR}/bin" RESULT_VARIABLE RUN_HIT ERROR_QUIET)
++#endif()
++#if(${RUN_HIT} EQUAL 0)
++# set(CMAKE_MODULE_PATH "${HIP_ROOT_DIR}/cmake" ${CMAKE_MODULE_PATH})
++# include(${HIP_SRC_PATH}/tests/hit/HIT.cmake)
++# include(${HIP_SRC_PATH}/tests/Tests.cmake)
++#else()
++# message(STATUS "Testing targets will not be available. To enable them please ensure that the HIP installation directory is writeable. Use -DCMAKE_INSTALL_PREFIX to specify a suitable location")
++#endif()
+
+ #############################
+ # Code analysis