summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2023-07-13 20:18:38 +0200
committerSam James <sam@gentoo.org>2023-07-26 07:28:40 +0100
commit41c74d31cf4774eb5f79e2a3c8966326b49a3e9a (patch)
tree205995ed87ed59ba05ffe3402804bdcac5f1f713 /dev-util/kyua
parentapp-editors/emacs: More specific dependency on emacs-common[gsettings] (diff)
downloadgentoo-41c74d31cf4774eb5f79e2a3c8966326b49a3e9a.tar.gz
gentoo-41c74d31cf4774eb5f79e2a3c8966326b49a3e9a.tar.bz2
gentoo-41c74d31cf4774eb5f79e2a3c8966326b49a3e9a.zip
dev-util/kyua: Add -std=c++14 in CXXFLAGS for clang-16 compatibility
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/31868 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/kyua')
-rw-r--r--dev-util/kyua/kyua-0.13-r3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/kyua/kyua-0.13-r3.ebuild b/dev-util/kyua/kyua-0.13-r3.ebuild
new file mode 100644
index 000000000000..4cd34b7ab883
--- /dev/null
+++ b/dev-util/kyua/kyua-0.13-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Testing framework for infrastructure software"
+HOMEPAGE="https://github.com/jmmv/kyua"
+SRC_URI="https://github.com/jmmv/kyua/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+
+# Tests fail
+RESTRICT="test"
+
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/atf
+ dev-lua/lutok
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( dev-libs/atf )
+"
+
+src_configure() {
+ # Uses std::auto_ptr (deprecated in c++11, removed in c++17)
+ append-cxxflags "-std=c++14"
+
+ default
+}
+
+src_install() {
+ default
+ rm -r "${ED}"/usr/tests || die
+}