summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2023-10-18 23:32:28 -0400
committerSam James <sam@gentoo.org>2023-10-25 03:22:25 +0100
commita1936383cafa03ef7eec5dab0793d2149adddf65 (patch)
tree605b3142988f180ec6f80c9ba1632c5e123b86ed /dev-util/lldb
parentdev-python/virtualenv: remove outdated test dependency on six (diff)
downloadgentoo-a1936383cafa03ef7eec5dab0793d2149adddf65.tar.gz
gentoo-a1936383cafa03ef7eec5dab0793d2149adddf65.tar.bz2
gentoo-a1936383cafa03ef7eec5dab0793d2149adddf65.zip
dev-util/lldb: drop outdated runtime dependency on six
In commit c919e59f4e6acf31497deb960ba15a42fadd4701 the obsolete cmake variable was removed which toggled using the system six. But the RDEPEND that went with it was left in. Since https://reviews.llvm.org/D131304, the six module is not used by lldb at all. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/lldb')
-rw-r--r--dev-util/lldb/lldb-16.0.6-r1.ebuild108
-rw-r--r--dev-util/lldb/lldb-17.0.3-r1.ebuild108
-rw-r--r--dev-util/lldb/lldb-17.0.3.9999.ebuild6
-rw-r--r--dev-util/lldb/lldb-18.0.0.9999.ebuild6
-rw-r--r--dev-util/lldb/lldb-18.0.0_pre20231019.ebuild6
5 files changed, 216 insertions, 18 deletions
diff --git a/dev-util/lldb/lldb-16.0.6-r1.ebuild b/dev-util/lldb/lldb-16.0.6-r1.ebuild
new file mode 100644
index 000000000000..cb029e8fb2fd
--- /dev/null
+++ b/dev-util/lldb/lldb-16.0.6-r1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit cmake llvm llvm.org python-single-r1
+
+DESCRIPTION="The LLVM debugger"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0/${LLVM_SOABI}"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~x86"
+IUSE="debug +libedit lzma ncurses +python test +xml"
+RESTRICT="test"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DEPEND="
+ libedit? ( dev-libs/libedit:0= )
+ lzma? ( app-arch/xz-utils:= )
+ ncurses? ( >=sys-libs/ncurses-5.9-r3:0= )
+ xml? ( dev-libs/libxml2:= )
+ ~sys-devel/clang-${PV}
+ ~sys-devel/llvm-${PV}
+"
+RDEPEND="
+ ${DEPEND}
+ python? (
+ ${PYTHON_DEPS}
+ )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-util/cmake-3.16
+ python? (
+ >=dev-lang/swig-3.0.11
+ )
+ test? (
+ $(python_gen_cond_dep "
+ ~dev-python/lit-${PV}[\${PYTHON_USEDEP}]
+ dev-python/psutil[\${PYTHON_USEDEP}]
+ ")
+ sys-devel/lld
+ )
+"
+
+LLVM_COMPONENTS=( lldb cmake llvm/utils )
+LLVM_TEST_COMPONENTS=( llvm/lib/Testing/Support third-party )
+llvm.org_set_globals
+
+pkg_setup() {
+ LLVM_MAX_SLOT=${LLVM_MAJOR} llvm_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ # LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
+ use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
+
+ local mycmakeargs=(
+ -DLLDB_ENABLE_CURSES=$(usex ncurses)
+ -DLLDB_ENABLE_LIBEDIT=$(usex libedit)
+ -DLLDB_ENABLE_PYTHON=$(usex python)
+ -DLLDB_ENABLE_LUA=OFF
+ -DLLDB_ENABLE_LZMA=$(usex lzma)
+ -DLLDB_ENABLE_LIBXML2=$(usex xml)
+ -DLLVM_ENABLE_TERMINFO=$(usex ncurses)
+
+ -DLLDB_INCLUDE_TESTS=$(usex test)
+
+ -DCLANG_LINK_CLANG_DYLIB=ON
+ # TODO: fix upstream to detect this properly
+ -DHAVE_LIBDL=ON
+ -DHAVE_LIBPTHREAD=ON
+
+ # normally we'd have to set LLVM_ENABLE_TERMINFO, HAVE_TERMINFO
+ # and TERMINFO_LIBS... so just force FindCurses.cmake to use
+ # ncurses with complete library set (including autodetection
+ # of -ltinfo)
+ -DCURSES_NEED_NCURSES=ON
+
+ -DLLDB_EXTERNAL_CLANG_RESOURCE_DIR="${BROOT}/usr/lib/clang/${LLVM_MAJOR}"
+
+ -DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
+ -DPython3_EXECUTABLE="${PYTHON}"
+ )
+ use test && mycmakeargs+=(
+ -DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
+ -DLLVM_LIT_ARGS="$(get_lit_flags)"
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ local -x LIT_PRESERVES_TMP=1
+ cmake_build check-lldb-{shell,unit}
+ # failures + hangs
+ #use python && cmake_build check-lldb-api
+}
+
+src_install() {
+ cmake_src_install
+ find "${D}" -name '*.a' -delete || die
+
+ use python && python_optimize
+}
diff --git a/dev-util/lldb/lldb-17.0.3-r1.ebuild b/dev-util/lldb/lldb-17.0.3-r1.ebuild
new file mode 100644
index 000000000000..61bd954e14a2
--- /dev/null
+++ b/dev-util/lldb/lldb-17.0.3-r1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit cmake llvm llvm.org python-single-r1
+
+DESCRIPTION="The LLVM debugger"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0/${LLVM_SOABI}"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~x86"
+IUSE="debug +libedit lzma ncurses +python test +xml"
+RESTRICT="test"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DEPEND="
+ libedit? ( dev-libs/libedit:0= )
+ lzma? ( app-arch/xz-utils:= )
+ ncurses? ( >=sys-libs/ncurses-5.9-r3:0= )
+ xml? ( dev-libs/libxml2:= )
+ ~sys-devel/clang-${PV}
+ ~sys-devel/llvm-${PV}
+"
+RDEPEND="
+ ${DEPEND}
+ python? (
+ ${PYTHON_DEPS}
+ )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-util/cmake-3.16
+ python? (
+ >=dev-lang/swig-3.0.11
+ )
+ test? (
+ $(python_gen_cond_dep "
+ ~dev-python/lit-${PV}[\${PYTHON_USEDEP}]
+ dev-python/psutil[\${PYTHON_USEDEP}]
+ ")
+ sys-devel/lld
+ )
+"
+
+LLVM_COMPONENTS=( lldb cmake llvm/utils )
+LLVM_TEST_COMPONENTS=( llvm/lib/Testing/Support third-party )
+llvm.org_set_globals
+
+pkg_setup() {
+ LLVM_MAX_SLOT=${LLVM_MAJOR} llvm_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ # LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
+ use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
+
+ local mycmakeargs=(
+ -DLLDB_ENABLE_CURSES=$(usex ncurses)
+ -DLLDB_ENABLE_LIBEDIT=$(usex libedit)
+ -DLLDB_ENABLE_PYTHON=$(usex python)
+ -DLLDB_ENABLE_LUA=OFF
+ -DLLDB_ENABLE_LZMA=$(usex lzma)
+ -DLLDB_ENABLE_LIBXML2=$(usex xml)
+ -DLLVM_ENABLE_TERMINFO=$(usex ncurses)
+
+ -DLLDB_INCLUDE_TESTS=$(usex test)
+
+ -DCLANG_LINK_CLANG_DYLIB=ON
+ # TODO: fix upstream to detect this properly
+ -DHAVE_LIBDL=ON
+ -DHAVE_LIBPTHREAD=ON
+
+ # normally we'd have to set LLVM_ENABLE_TERMINFO, HAVE_TERMINFO
+ # and TERMINFO_LIBS... so just force FindCurses.cmake to use
+ # ncurses with complete library set (including autodetection
+ # of -ltinfo)
+ -DCURSES_NEED_NCURSES=ON
+
+ -DCLANG_RESOURCE_DIR="../../../clang/${LLVM_MAJOR}"
+
+ -DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
+ -DPython3_EXECUTABLE="${PYTHON}"
+ )
+ use test && mycmakeargs+=(
+ -DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
+ -DLLVM_LIT_ARGS="$(get_lit_flags)"
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ local -x LIT_PRESERVES_TMP=1
+ cmake_build check-lldb-{shell,unit}
+ # failures + hangs
+ #use python && cmake_build check-lldb-api
+}
+
+src_install() {
+ cmake_src_install
+ find "${D}" -name '*.a' -delete || die
+
+ use python && python_optimize
+}
diff --git a/dev-util/lldb/lldb-17.0.3.9999.ebuild b/dev-util/lldb/lldb-17.0.3.9999.ebuild
index 85f3da6a1874..1459848607aa 100644
--- a/dev-util/lldb/lldb-17.0.3.9999.ebuild
+++ b/dev-util/lldb/lldb-17.0.3.9999.ebuild
@@ -26,9 +26,6 @@ DEPEND="
RDEPEND="
${DEPEND}
python? (
- $(python_gen_cond_dep '
- dev-python/six[${PYTHON_USEDEP}]
- ')
${PYTHON_DEPS}
)
"
@@ -37,9 +34,6 @@ BDEPEND="
>=dev-util/cmake-3.16
python? (
>=dev-lang/swig-3.0.11
- $(python_gen_cond_dep '
- dev-python/six[${PYTHON_USEDEP}]
- ')
)
test? (
$(python_gen_cond_dep "
diff --git a/dev-util/lldb/lldb-18.0.0.9999.ebuild b/dev-util/lldb/lldb-18.0.0.9999.ebuild
index 85f3da6a1874..1459848607aa 100644
--- a/dev-util/lldb/lldb-18.0.0.9999.ebuild
+++ b/dev-util/lldb/lldb-18.0.0.9999.ebuild
@@ -26,9 +26,6 @@ DEPEND="
RDEPEND="
${DEPEND}
python? (
- $(python_gen_cond_dep '
- dev-python/six[${PYTHON_USEDEP}]
- ')
${PYTHON_DEPS}
)
"
@@ -37,9 +34,6 @@ BDEPEND="
>=dev-util/cmake-3.16
python? (
>=dev-lang/swig-3.0.11
- $(python_gen_cond_dep '
- dev-python/six[${PYTHON_USEDEP}]
- ')
)
test? (
$(python_gen_cond_dep "
diff --git a/dev-util/lldb/lldb-18.0.0_pre20231019.ebuild b/dev-util/lldb/lldb-18.0.0_pre20231019.ebuild
index 85f3da6a1874..1459848607aa 100644
--- a/dev-util/lldb/lldb-18.0.0_pre20231019.ebuild
+++ b/dev-util/lldb/lldb-18.0.0_pre20231019.ebuild
@@ -26,9 +26,6 @@ DEPEND="
RDEPEND="
${DEPEND}
python? (
- $(python_gen_cond_dep '
- dev-python/six[${PYTHON_USEDEP}]
- ')
${PYTHON_DEPS}
)
"
@@ -37,9 +34,6 @@ BDEPEND="
>=dev-util/cmake-3.16
python? (
>=dev-lang/swig-3.0.11
- $(python_gen_cond_dep '
- dev-python/six[${PYTHON_USEDEP}]
- ')
)
test? (
$(python_gen_cond_dep "