summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Nespithal <richard@nespithal.com>2016-11-23 16:40:08 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-01-18 00:07:28 +0100
commit961157ef75c206f7e38bcddf1422fc9f76e4eb86 (patch)
tree6070c99e69a65519bc5a3770a30983cbd4f36acd /dev-util/lxqt-build-tools
parentwww-apps/kibana-bin: version bump to 4.6.4/5.1.2. (diff)
downloadgentoo-961157ef75c206f7e38bcddf1422fc9f76e4eb86.tar.gz
gentoo-961157ef75c206f7e38bcddf1422fc9f76e4eb86.tar.bz2
gentoo-961157ef75c206f7e38bcddf1422fc9f76e4eb86.zip
dev-util/lxqt-build-tools: new package.
Gentoo-Bug: https://bugs.gentoo.org/604344 Closes: https://github.com/gentoo/gentoo/pull/2897
Diffstat (limited to 'dev-util/lxqt-build-tools')
-rw-r--r--dev-util/lxqt-build-tools/Manifest1
-rw-r--r--dev-util/lxqt-build-tools/lxqt-build-tools-0.2.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/lxqt-build-tools/Manifest b/dev-util/lxqt-build-tools/Manifest
new file mode 100644
index 000000000000..c0a62e85ad99
--- /dev/null
+++ b/dev-util/lxqt-build-tools/Manifest
@@ -0,0 +1 @@
+DIST lxqt-build-tools-0.2.0.tar.xz 15552 SHA256 4b2b6788260e167358f3bb295cc2faa820cb52670d3213a6317419db893037d2 SHA512 40349710a20d3f06761c57b5d40aa05cb194fa4b50d1e41e4bd7e6adf1beb5c7209f3d4965869a301369df17ec1d75f55aede7ab0fe88a55d692cd56d72121de WHIRLPOOL 9725e8181a7f6e6e05c172336b5b489caf9573e7d6beb472ffd9a6ae8769f961b285f43d3ef05103e0374c50abf55afc81d028e487668d1b0cbe8fcc2787a878
diff --git a/dev-util/lxqt-build-tools/lxqt-build-tools-0.2.0.ebuild b/dev-util/lxqt-build-tools/lxqt-build-tools-0.2.0.ebuild
new file mode 100644
index 000000000000..0e20e2176158
--- /dev/null
+++ b/dev-util/lxqt-build-tools/lxqt-build-tools-0.2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="LXQt Build tools"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="dev-qt/qtcore:5"
+
+src_configure() {
+ cmake-utils_src_configure
+}