summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2024-04-17 20:42:45 +0300
committerJimi Huotari <chiitoo@gentoo.org>2024-06-15 00:48:28 +0300
commitb9d9af563f9ad9fbe0974c5d8e9bbb47b5cfc769 (patch)
treeddc98f5f53ffb2a86423e17c85dd8bbdbe906596 /dev-util/lxqt-build-tools
parentmetadata/stabilization-groups: add texlive group (diff)
downloadgentoo-b9d9af563f9ad9fbe0974c5d8e9bbb47b5cfc769.tar.gz
gentoo-b9d9af563f9ad9fbe0974c5d8e9bbb47b5cfc769.tar.bz2
gentoo-b9d9af563f9ad9fbe0974c5d8e9bbb47b5cfc769.zip
dev-util/lxqt-build-tools: add 2.0.0
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'dev-util/lxqt-build-tools')
-rw-r--r--dev-util/lxqt-build-tools/Manifest1
-rw-r--r--dev-util/lxqt-build-tools/lxqt-build-tools-2.0.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-util/lxqt-build-tools/Manifest b/dev-util/lxqt-build-tools/Manifest
index 53a00dc01519..10a379efbcb6 100644
--- a/dev-util/lxqt-build-tools/Manifest
+++ b/dev-util/lxqt-build-tools/Manifest
@@ -1 +1,2 @@
DIST lxqt-build-tools-0.13.0.tar.xz 25480 BLAKE2B aebbcb55851b0acc00bf4d34e3846e12a3d503e4f7238ba57d7d6b3df44ccd8e6dbe5fc1986ed722dfd4384ad17f22be14fa0c6270b3ed385ae7cd4ff5711e3e SHA512 ffb300159d6bbbdbe9d43d261a5028342f24057c943cf8dab5093d53b72bf5700de8f545914d454993e949d64aba77e3d01cbe68e8a4b4f6ca9f9f9693de3e0b
+DIST lxqt-build-tools-2.0.0.tar.xz 26072 BLAKE2B a549dbe4b2e93d33d0238efe4e419c867db49e626436c243c8080cd4d925212edfb531bb2d9b661d675b7c9b9fec076a4a6f2d144f414ebc3babacada75877e3 SHA512 4fe92af82d55bda8fc1b6dc44998ed64b031e33a5c19e9206c1822375b8aa8abbf5f5b94d3c5ebe6d5d318f8821664ee308064b7adb9081e08047a4456cc6a66
diff --git a/dev-util/lxqt-build-tools/lxqt-build-tools-2.0.0.ebuild b/dev-util/lxqt-build-tools/lxqt-build-tools-2.0.0.ebuild
new file mode 100644
index 000000000000..52e9e5be77b7
--- /dev/null
+++ b/dev-util/lxqt-build-tools/lxqt-build-tools-2.0.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt Build Tools"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ >=dev-qt/qtbase-6.6:6
+"
+RDEPEND="${DEPEND}
+ !<=app-arch/lxqt-archiver-1
+ !<=app-misc/qtxdg-tools-4
+ !<=dev-libs/libqtxdg-4
+ !<=gui-libs/xdg-desktop-portal-lxqt-1
+ !<=lxqt-base/liblxqt-2
+ !<=lxqt-base/libsysstat-1
+ !<=lxqt-base/lxqt-about-2
+ !<=lxqt-base/lxqt-admin-2
+ !<=lxqt-base/lxqt-config-2
+ !<=lxqt-base/lxqt-globalkeys-2
+ !<=lxqt-base/lxqt-menu-data-2
+ !<=lxqt-base/lxqt-meta-2
+ !<=lxqt-base/lxqt-notificationd-2
+ !<=lxqt-base/lxqt-openssh-askpass-2
+ !<=lxqt-base/lxqt-panel-2
+ !<=lxqt-base/lxqt-policykit-2
+ !<=lxqt-base/lxqt-powermanagement-2
+ !<=lxqt-base/lxqt-qtplugin-2
+ !<=lxqt-base/lxqt-runner-2
+ !<=lxqt-base/lxqt-session-2
+ !<=lxqt-base/lxqt-sudo-2
+ !<=media-gfx/lximage-qt-2
+ !<=x11-libs/libfm-qt-2
+ !<=x11-libs/qtermwidget-2
+ !x11-misc/obconf-qt
+ !<=x11-misc/pcmanfm-qt-2
+ !<=x11-misc/qps-2.9
+ !<=x11-misc/screengrab-2.8
+ !<=x11-terms/qterminal-2
+ !<=x11-themes/lxqt-themes-2
+"