summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Fore <csfore@posteo.net>2024-01-06 19:35:48 -0500
committerSam James <sam@gentoo.org>2024-01-20 13:27:19 +0000
commita2aa8ccd3c1522c88386de4904d4bf77fcafb0d8 (patch)
treece8ae1ee279ce24ca01a0a82953e7cb6ab93f756 /dev-util/re2c/re2c-3.1.ebuild
parentapp-crypt/nitrocli: Add patch fixing musl 1.2.4 build (diff)
downloadgentoo-a2aa8ccd3c1522c88386de4904d4bf77fcafb0d8.tar.gz
gentoo-a2aa8ccd3c1522c88386de4904d4bf77fcafb0d8.tar.bz2
gentoo-a2aa8ccd3c1522c88386de4904d4bf77fcafb0d8.zip
dev-util/re2c: add 3.1, security bump
[sam: Add explicit --enable-rust like for Go. It's already on by default though.] Bug: https://bugs.gentoo.org/836372 Signed-off-by: Christopher Fore <csfore@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/34681 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/re2c/re2c-3.1.ebuild')
-rw-r--r--dev-util/re2c/re2c-3.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/re2c/re2c-3.1.ebuild b/dev-util/re2c/re2c-3.1.ebuild
new file mode 100644
index 000000000000..d285e9d937e8
--- /dev/null
+++ b/dev-util/re2c/re2c-3.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit python-any-r1
+
+DESCRIPTION="Tool for generating C-based recognizers from regular expressions"
+HOMEPAGE="https://re2c.org/"
+SRC_URI="https://github.com/skvadrik/re2c/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="debug test"
+
+RESTRICT="!test? ( test )"
+
+# python is used only as a test driver
+BDEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ econf \
+ --enable-golang \
+ --enable-rust \
+ ac_cv_path_BISON="no" \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r README.md CHANGELOG examples
+}