summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2017-01-25 20:38:44 +0100
committerDirkjan Ochtman <djc@gentoo.org>2017-01-25 20:38:58 +0100
commitbf7c20bc2e7133623372e42856427d6465a5535d (patch)
treec57bc0d9b1e969aa1e10969160cd6c6a82209534 /dev-util/rebar/rebar-2.6.4.ebuild
parentdev-ml/labltk-8.06.2-r0: stable on alpha (diff)
downloadgentoo-bf7c20bc2e7133623372e42856427d6465a5535d.tar.gz
gentoo-bf7c20bc2e7133623372e42856427d6465a5535d.tar.bz2
gentoo-bf7c20bc2e7133623372e42856427d6465a5535d.zip
dev-util/rebar: version bump to 2.6.4 (fixes bug 607120)
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-util/rebar/rebar-2.6.4.ebuild')
-rw-r--r--dev-util/rebar/rebar-2.6.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/rebar/rebar-2.6.4.ebuild b/dev-util/rebar/rebar-2.6.4.ebuild
new file mode 100644
index 000000000000..bc8437bccf43
--- /dev/null
+++ b/dev-util/rebar/rebar-2.6.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit bash-completion-r1
+
+DESCRIPTION="A sophisticated build-tool for Erlang projects that follows OTP principles"
+HOMEPAGE="https://github.com/rebar/rebar"
+SRC_URI="https://github.com/rebar/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/erlang"
+DEPEND="${RDEPEND}"
+
+src_test() {
+ emake xref
+}
+
+src_install() {
+ dobin rebar
+ dodoc rebar.config.sample THANKS
+ dobashcomp priv/shell-completion/bash/${PN}
+}