summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2022-07-04 14:08:01 -0500
committerJohn Helmert III <ajak@gentoo.org>2022-07-04 15:01:06 -0500
commitde8b82fad57e57633c0d3e4c666e4c8b916501cc (patch)
tree6566cab9967aaac5ec0cc1408c2d9c38b80479d3 /dev-util/rizin
parentx11-libs/pango: Version bump to 1.50.8 (diff)
downloadgentoo-de8b82fad57e57633c0d3e4c666e4c8b916501cc.tar.gz
gentoo-de8b82fad57e57633c0d3e4c666e4c8b916501cc.tar.bz2
gentoo-de8b82fad57e57633c0d3e4c666e4c8b916501cc.zip
dev-util/rizin: add 0.4.0, enable py3.11
Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'dev-util/rizin')
-rw-r--r--dev-util/rizin/Manifest2
-rw-r--r--dev-util/rizin/files/rizin-0.4.0-never-rebuild-parser.patch38
-rw-r--r--dev-util/rizin/rizin-0.4.0.ebuild94
3 files changed, 134 insertions, 0 deletions
diff --git a/dev-util/rizin/Manifest b/dev-util/rizin/Manifest
index c38b64e65193..39d5687e41c8 100644
--- a/dev-util/rizin/Manifest
+++ b/dev-util/rizin/Manifest
@@ -1,2 +1,4 @@
DIST rizin-src-v0.3.4.tar.xz 10411432 BLAKE2B 99745f069e6bd72aec6a6f335f3aa0ccc46ebf186b1dc0aaf32b4f95d2be4bb49e8d3d976a72978c22fce82d896e70bf8403568e100b73898731045ef06a2ad5 SHA512 cda35afe8c031f3207c055ed31d7f76a46b7addd04cead0f5aadf0733b66f4dd953ca16f054b47da7921d4726d6ea1250436012954a9755c1cd524a8fd0d670c
+DIST rizin-src-v0.4.0.tar.xz 11432232 BLAKE2B 095ca9d317296afca9514a70f208e9aa87fc426e6b7e41163f64d5a1192a4d9ccd8ece9c4f13a24fc973668dece625fa13ad75542695a66c542fe2f0d9e66733 SHA512 9d576bee48e5ceae46b4e309c53e01b82edf89a95046f576e1c38fefa73353d6d1f04e6d444332324387d4e115bc87659a358629f7277a41dfef44c82364547b
+DIST rizin-testbins-64a6f26369bf5893ecc20cb8984a5ad506ef8566.tar.gz 172591261 BLAKE2B e78843fd95ac0406f66490b7253206e77787fc65780bc7c6a67d26aa9618a6f85803a88724ad424a7bdeeb20d95ebf9314e582029ac778d7d4de4f207ff54aad SHA512 ada4a3faad94553f0f2802419ba604177bb66d332b1a351effd485d65bd8365abb36d736486bbd0bcbc0da584ad4a2edaa7aa3cb62fa12811282c2e0afecb950
DIST rizin-testbins-aa6a88dcdfaad54335e3935c16ce21a124ff861d.tar.gz 127254454 BLAKE2B e7a4536be7169abd197c2128e103b8d669fbb7532ce265b27da3ce347b1aa58c8a96c95d85cf7700f66a44c041a0575175de3a0e176a0d31c490f7ccfb2f6d6b SHA512 20cf299e5324793f07f8a2fdcfa3d66c3a418f09bfc6a272e35ab31d4a64408bf91532ae431098dede1a2d0ad0b1c02433304c514816d98dc068f6c0528a4099
diff --git a/dev-util/rizin/files/rizin-0.4.0-never-rebuild-parser.patch b/dev-util/rizin/files/rizin-0.4.0-never-rebuild-parser.patch
new file mode 100644
index 000000000000..0e6e95c09318
--- /dev/null
+++ b/dev-util/rizin/files/rizin-0.4.0-never-rebuild-parser.patch
@@ -0,0 +1,38 @@
+commit 7af437dbedaaa478b579d19133b6711923b037d8
+Author: John Helmert III <ajak@gentoo.org>
+Date: Mon Jul 4 12:44:43 2022 -0500
+
+ subprojects/rizin-shell-parser/src: Never rebuild parser.c
+
+ This requires dev-libs/tree-sitter[ts-cli] and net-libs/nodejs, both
+ of which would be heavy new dependencies. However, these are only
+ needed to rebuild the already-existing tree-sitter parser, which
+ doesn't do much for us (if anything) since it already exists. In this
+ case, it's better to just reduce fragility by unconditionally
+ disabling this.
+
+ Newly forward-ported from the 0.3.2 version.
+
+ Bug: https://bugs.gentoo.org/830068
+ Signed-off-by: John Helmert III <ajak@gentoo.org>
+
+diff --git a/subprojects/rizin-shell-parser/src/meson.build b/subprojects/rizin-shell-parser/src/meson.build
+index ae31896a98..14324daba0 100644
+--- a/subprojects/rizin-shell-parser/src/meson.build
++++ b/subprojects/rizin-shell-parser/src/meson.build
+@@ -1,14 +1,4 @@
+-tree_sitter_bin = find_program('tree-sitter', required: false)
+-node_bin = find_program('node', required: false)
+-if tree_sitter_bin.found() and node_bin.found() and tree_sitter_dep.type_name() != 'internal'
+- parser_c = custom_target('parser_src_c',
+- command: [tree_sitter_wrap_py, tree_sitter_bin, '@OUTDIR@/..', '@INPUT@'],
+- input: [grammar_js],
+- output: 'parser.c',
+- )
+-else
+- parser_c = files('parser.c')
+-endif
++parser_c = files('parser.c')
+
+ shell_parser_files = [files('scanner.c'), parser_c]
+ shell_parser_inc = [include_directories('tree_sitter')]
diff --git a/dev-util/rizin/rizin-0.4.0.ebuild b/dev-util/rizin/rizin-0.4.0.ebuild
new file mode 100644
index 000000000000..7602de44178a
--- /dev/null
+++ b/dev-util/rizin/rizin-0.4.0.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+# This is the commit that the CI for the release commit used
+BINS_COMMIT="64a6f26369bf5893ecc20cb8984a5ad506ef8566"
+
+inherit meson python-any-r1
+
+DESCRIPTION="reverse engineering framework for binary analysis"
+HOMEPAGE="https://rizin.re/"
+
+SRC_URI="mirror+https://github.com/rizinorg/rizin/releases/download/v${PV}/rizin-src-v${PV}.tar.xz
+ test? ( https://github.com/rizinorg/rizin-testbins/archive/${BINS_COMMIT}.tar.gz -> rizin-testbins-${BINS_COMMIT}.tar.gz )"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+LICENSE="Apache-2.0 BSD LGPL-3 MIT"
+SLOT="0/${PV}"
+IUSE="test"
+
+# Need to audit licenses of the binaries used for testing
+RESTRICT="fetch !test? ( test )"
+
+RDEPEND="
+ sys-apps/file
+ app-arch/lz4:0=
+ <dev-libs/capstone-5:0=
+ dev-libs/libuv:0=
+ dev-libs/libzip:0=
+ dev-libs/openssl:0=
+ >=dev-libs/tree-sitter-0.19.0
+ dev-libs/xxhash
+ sys-libs/zlib:0=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.4.0-never-rebuild-parser.patch"
+)
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_prepare() {
+ default
+
+ local py_to_mangle=(
+ librz/core/cmd_descs/cmd_descs_generate.py
+ subprojects/lz4-1.9.3/contrib/meson/meson/GetLz4LibraryVersion.py
+ subprojects/lz4-1.9.3/contrib/meson/meson/InstallSymlink.py
+ subprojects/lz4-1.9.3/tests/test-lz4-list.py
+ subprojects/lz4-1.9.3/tests/test-lz4-speed.py
+ subprojects/lz4-1.9.3/tests/test-lz4-versions.py
+ sys/clang-format.py
+ test/fuzz/scripts/fuzz_rz_asm.py
+ test/scripts/gdbserver.py
+ )
+
+ python_fix_shebang "${py_to_mangle[@]}"
+
+ if use test; then
+ cp -r "${WORKDIR}/rizin-testbins-${BINS_COMMIT}" "${S}/test/bins" || die
+ cp -r "${WORKDIR}/rizin-testbins-${BINS_COMMIT}" "${S}" || die
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dcli=enabled
+ -Duse_sys_capstone=enabled
+ -Duse_sys_magic=enabled
+ -Duse_sys_libzip=enabled
+ -Duse_sys_zlib=enabled
+ -Duse_sys_lz4=enabled
+ -Duse_sys_xxhash=enabled
+ -Duse_sys_openssl=enabled
+ -Duse_sys_tree_sitter=enabled
+
+ $(meson_use test enable_tests)
+ $(meson_use test enable_rz_test)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ # We can select running either unit or integration tests, or all of
+ # them by not passing --suite. According to upstream, integration
+ # tests are more fragile and unit tests are sufficient for testing
+ # packaging, so only run those.
+ meson_src_test --suite unit
+}