summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHolger Hoffstätte <holger@applied-asynchrony.com>2024-01-01 15:58:04 +0100
committerSam James <sam@gentoo.org>2024-01-11 14:12:37 +0000
commitcdc4d7296f423fc28e82b4cc585c968115283996 (patch)
tree2ccc6229e8a96c2945ea5222366499f10d723bd4 /dev-util/scap-driver
parentdev-util/scap-driver: fix build on kernel 6.7 (diff)
downloadgentoo-cdc4d7296f423fc28e82b4cc585c968115283996.tar.gz
gentoo-cdc4d7296f423fc28e82b4cc585c968115283996.tar.bz2
gentoo-cdc4d7296f423fc28e82b4cc585c968115283996.zip
dev-util/scap-driver: clean up old
Signed-off-by: Holger Hoffstätte <holger@applied-asynchrony.com> Closes: https://github.com/gentoo/gentoo/pull/34593 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/scap-driver')
-rw-r--r--dev-util/scap-driver/scap-driver-0.29.3.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/dev-util/scap-driver/scap-driver-0.29.3.ebuild b/dev-util/scap-driver/scap-driver-0.29.3.ebuild
deleted file mode 100644
index b7f0615e4841..000000000000
--- a/dev-util/scap-driver/scap-driver-0.29.3.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake linux-mod
-
-DESCRIPTION="Kernel module for dev-util/sysdig"
-HOMEPAGE="https://sysdig.com/"
-
-# The driver is part of falcosecurity/libs, but for versioning reasons we cannot (yet)
-# use semver-released packages; instead we pull in a commit that is used and known
-# to work with sysdig, see sysdig/cmake/modules/falcosecurity-libs.cmake for details.
-# For now the commit here and the one referenced in sysdig should be in sync.
-LIBS_COMMIT="e5c53d648f3c4694385bbe488e7d47eaa36c229a"
-SRC_URI="https://github.com/falcosecurity/libs/archive/${LIBS_COMMIT}.tar.gz -> falcosecurity-libs-${LIBS_COMMIT}.tar.gz"
-S="${WORKDIR}/libs-${LIBS_COMMIT}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-
-RDEPEND="!<dev-util/sysdig-${PV}[modules]"
-
-CONFIG_CHECK="HAVE_SYSCALL_TRACEPOINTS ~TRACEPOINTS"
-
-PATCHES=( "${FILESDIR}"/${PV}-fix-kmod-build-on-5.18+.patch )
-
-src_configure() {
- local mycmakeargs=(
- # we will use linux-mod, so just pretend to use bundled deps
- # in order to make it through the cmake setup.
- -DUSE_BUNDLED_DEPS=ON
- -DCREATE_TEST_TARGETS=OFF
- -DDRIVER_VERSION=${LIBS_COMMIT}
- )
-
- cmake_src_configure
-
- # setup linux-mod ugliness
- MODULE_NAMES="scap(extra:${BUILD_DIR}/driver/src:)"
- BUILD_PARAMS='KERNELDIR="${KERNEL_DIR}"'
- # work with clang-built kernels (#816024)
- if linux_chkconfig_present CC_IS_CLANG; then
- BUILD_PARAMS+=' CC=${CHOST}-clang'
- if linux_chkconfig_present LD_IS_LLD; then
- BUILD_PARAMS+=' LD=ld.lld'
- if linux_chkconfig_present LTO_CLANG_THIN; then
- # kernel enables cache by default leading to sandbox violations
- BUILD_PARAMS+=' ldflags-y=--thinlto-cache-dir= LDFLAGS_MODULE=--thinlto-cache-dir='
- fi
- fi
- fi
-
- BUILD_TARGETS="all"
-}