summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-08 15:14:52 +0100
committerSam James <sam@gentoo.org>2024-08-08 15:15:49 +0100
commit45738f7b8b16b9b714dbc553f99c1661459b5f7b (patch)
tree08eb596e58ba30cb76ddaf8b30f2532ea5207afd /dev-util/vulkan-headers
parentsys-fs/bees: bump to 0.10-r1 for new patches (diff)
downloadgentoo-45738f7b8b16b9b714dbc553f99c1661459b5f7b.tar.gz
gentoo-45738f7b8b16b9b714dbc553f99c1661459b5f7b.tar.bz2
gentoo-45738f7b8b16b9b714dbc553f99c1661459b5f7b.zip
dev-util/vulkan-headers: disable modules
C++ modules are in no way production ready at all. Unfortunately, upstream enabled them by default, so let's undo that. Noticed because I hit a -fcompare-debug failure and then not one but two ICEs when poking at that. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/vulkan-headers')
-rw-r--r--dev-util/vulkan-headers/vulkan-headers-1.3.290.0-r1.ebuild (renamed from dev-util/vulkan-headers/vulkan-headers-1.3.290.0.ebuild)8
-rw-r--r--dev-util/vulkan-headers/vulkan-headers-9999.ebuild8
2 files changed, 16 insertions, 0 deletions
diff --git a/dev-util/vulkan-headers/vulkan-headers-1.3.290.0.ebuild b/dev-util/vulkan-headers/vulkan-headers-1.3.290.0-r1.ebuild
index df7a3c745a49..43831b775de1 100644
--- a/dev-util/vulkan-headers/vulkan-headers-1.3.290.0.ebuild
+++ b/dev-util/vulkan-headers/vulkan-headers-1.3.290.0-r1.ebuild
@@ -20,3 +20,11 @@ HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Headers"
LICENSE="Apache-2.0"
SLOT="0"
+
+src_configure() {
+ local mycmakeargs=(
+ -DVULKAN_HEADERS_ENABLE_MODULE=OFF
+ )
+
+ cmake_src_configure
+}
diff --git a/dev-util/vulkan-headers/vulkan-headers-9999.ebuild b/dev-util/vulkan-headers/vulkan-headers-9999.ebuild
index df7a3c745a49..43831b775de1 100644
--- a/dev-util/vulkan-headers/vulkan-headers-9999.ebuild
+++ b/dev-util/vulkan-headers/vulkan-headers-9999.ebuild
@@ -20,3 +20,11 @@ HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Headers"
LICENSE="Apache-2.0"
SLOT="0"
+
+src_configure() {
+ local mycmakeargs=(
+ -DVULKAN_HEADERS_ENABLE_MODULE=OFF
+ )
+
+ cmake_src_configure
+}