summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-08-30 09:22:05 +0300
committerSam James <sam@gentoo.org>2023-08-30 07:33:19 +0100
commit190ab28b73cc8f2e8f51fde63b494dd570f8cd2b (patch)
treed7767b810235744234a2ab0f7657520b224aad2c /dev-util
parentmail-mta/courier: use simpler bash expression (diff)
downloadgentoo-190ab28b73cc8f2e8f51fde63b494dd570f8cd2b.tar.gz
gentoo-190ab28b73cc8f2e8f51fde63b494dd570f8cd2b.tar.bz2
gentoo-190ab28b73cc8f2e8f51fde63b494dd570f8cd2b.zip
dev-util/qbs: remove comment inside substitution
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/32525 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/qbs/qbs-1.19.1.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/dev-util/qbs/qbs-1.19.1.ebuild b/dev-util/qbs/qbs-1.19.1.ebuild
index 3339bb574287..28e160fd13ed 100644
--- a/dev-util/qbs/qbs-1.19.1.ebuild
+++ b/dev-util/qbs/qbs-1.19.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -58,11 +58,15 @@ src_prepare() {
echo "SUBDIRS = $(usev test auto)" >> tests/tests.pro
# skip several tests that fail and/or have additional deps
- sed -i \
- -e 's/findArchiver(binaryName,.*/"";/' `# requires zip and jar` \
- -e 's/p\.value("nodejs\./true||&/' `# requires nodejs, bug 527652` \
- -e 's/\(p\.value\|m_qbsStderr\.contains\)("typescript\./true||&/' `# requires nodejs and typescript` \
- tests/auto/blackbox/tst_blackbox.cpp || die
+ local SKIP_TESTS_ARGS=(
+ # requires zip and jar
+ -e 's/findArchiver(binaryName,.*/"";/'
+ # requires nodejs, bug 527652
+ -e 's/p\.value("nodejs\./true||&/'
+ # requires nodejs and typescript
+ -e 's/\(p\.value\|m_qbsStderr\.contains\)("typescript\./true||&/'
+ )
+ sed -i tests/auto/blackbox/tst_blackbox.cpp "${SKIP_TESTS_ARGS[@]}" || die
sed -i -re '/blackbox-(android|apple|java)\.pro/ d' tests/auto/auto.pro || die
}