summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-07-27 14:25:03 -0500
committerWilliam Hubbs <williamh@gentoo.org>2023-07-27 14:25:31 -0500
commit72e8b19cccdaf23db1cdfd62e7c1ccaf2d5fa387 (patch)
tree11af691f7f12900f8bfdbf03daf192e4eb87027a /dev-util
parentprofiles: mask dev-php/swoole-async for removal. (diff)
downloadgentoo-72e8b19cccdaf23db1cdfd62e7c1ccaf2d5fa387.tar.gz
gentoo-72e8b19cccdaf23db1cdfd62e7c1ccaf2d5fa387.tar.bz2
gentoo-72e8b19cccdaf23db1cdfd62e7c1ccaf2d5fa387.zip
dev-util/gitlab-runner: add 16.2.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-16.2.0.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index 91651d4d834b..fbb73f38022b 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -4,3 +4,5 @@ DIST gitlab-runner-16.0.2-deps.tar.xz 161413208 BLAKE2B 8e8ee06371bd8482a39c129b
DIST gitlab-runner-16.0.2.tar.bz2 1346109 BLAKE2B ed8bf9a893fc4d38aeb9ef2e1823eb0940b23e12fd2236f5ffbb90832634b244201d8518e1e5231ee7d4445ac3742ca47b1f3d8a66d06a93811e040d9229d19e SHA512 54b1e7c0b5838254aa30199e62760a845a9bba0a04cc9963b0bdaa776c7219bf0acee71a62f3c958b3d22d9aaf3380bf236228f18ac3e0f3d615578a1d3f9b87
DIST gitlab-runner-16.1.0-deps.tar.xz 199599928 BLAKE2B 585dd1038106e5f0f397fc801309449e19da4af3419874d4dba178ecdf3109950fb39c4e20578ad388db455aeb20607aeb3d505f8304124fdc07747f43108062 SHA512 c7b714fe60f4dd8cda6ae3ee9700d6d8c748b42c3499e0d3a5377008e6eac55fc99fbea693a72ecf38fb10be7f56e0d72c4a12ffe7bac8ea1de29448fa934707
DIST gitlab-runner-16.1.0.tar.bz2 1353795 BLAKE2B e0f8fc23c9e50dc2bbe50187c7256381678504aef1d23e82a2fdbaef10f0c502ba8dfd31bbae450d22362b9b82b81184895dac1353f5dcbd32cefe9a263a7a81 SHA512 2fe31471e80943e24b7667ee8d544d6b031435c88ab2fb58911752b248d2e0293fdede0996e2715f54ec71b4c6d58aa422b87fb112e005c1022af0d4c1a80caa
+DIST gitlab-runner-16.2.0-deps.tar.xz 200381264 BLAKE2B 61a9d094c251f299e98718883359433545294c8d862872bcf1b4558d721455bd83d867b198af4ec9a217b7e67be3084539955613640ff1829ae6c39a4bc82926 SHA512 9ffbee5f3b179d5a85f3d322b109b538c6c78874b80c5f593fbfe8ccb993fa0b2028665354f10a0774c7a130c12170bc53cc3315f34ec3b6941febc726e113df
+DIST gitlab-runner-16.2.0.tar.bz2 1361100 BLAKE2B 19df94ba47188ad696f79df56595f34a2fa7c82971549172a8acc65dd04228aed077d675f85e35e8731ae4b1e72003333ebe667772dce66e6bb17a0ad84a522b SHA512 75097c09b065c8486a5d23219dcb8e36c2baac254e0b09811dd725cf493d959d9b2d3a2c9c130d208a50c1355e19faa749a6d5bb58e1681f782279eca277605e
diff --git a/dev-util/gitlab-runner/gitlab-runner-16.2.0.ebuild b/dev-util/gitlab-runner/gitlab-runner-16.2.0.ebuild
new file mode 100644
index 000000000000..4a6bef12c466
--- /dev/null
+++ b/dev-util/gitlab-runner/gitlab-runner-16.2.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# make sure this gets updated for every bump
+GIT_COMMIT=782e15da
+
+DESCRIPTION="The official GitLab Runner, written in Go"
+HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
+SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 ~riscv"
+
+COMMON_DEPEND="acct-group/gitlab-runner
+ acct-user/gitlab-runner"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-go/gox"
+
+DOCS=( docs CHANGELOG.md README.md config.toml.example )
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake \
+ BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
+ GOX="${EPREFIX}/usr/bin/gox" \
+ REVISION=${GIT_COMMIT} \
+ VERSION=${PV} \
+ runner-bin-host
+}
+
+src_test() {
+ CI=0 ego test
+}
+
+src_install() {
+ dobin out/binaries/gitlab-runner
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+ keepdir /{etc,var/log}/${PN}
+ fperms 0700 /{etc,var/log}/gitlab-runner
+ fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process gitlab-runner.conf
+ [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
+ elog
+ elog "To use the runner, you need to register it with this command:"
+ elog "# gitlab-runner register"
+ elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
+}