summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSv. Lockal <lockalsash@gmail.com>2024-01-01 18:05:03 +0000
committerSam James <sam@gentoo.org>2024-01-06 07:20:19 +0000
commit9fb562001ae0cf172c89dfa4561c6af6c996a406 (patch)
tree7288af546f280154b3128c9815f992456c1dbf2e /dev-util
parentdev-python/apprise: Add python@ as co-maint. (diff)
downloadgentoo-9fb562001ae0cf172c89dfa4561c6af6c996a406.tar.gz
gentoo-9fb562001ae0cf172c89dfa4561c6af6c996a406.tar.bz2
gentoo-9fb562001ae0cf172c89dfa4561c6af6c996a406.zip
dev-util/hip: fix linker error for ld.lld: error: version script assignment issue
Closes: https://bugs.gentoo.org/921171 See also: https://github.com/gentoo/gentoo/pull/29097 Signed-off-by: Sv. Lockal <lockalsash@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34595 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/hip/hip-6.0.0.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-util/hip/hip-6.0.0.ebuild b/dev-util/hip/hip-6.0.0.ebuild
index 9f8f62ca11ad..40efa9317ab4 100644
--- a/dev-util/hip/hip-6.0.0.ebuild
+++ b/dev-util/hip/hip-6.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -81,6 +81,16 @@ src_prepare() {
src_configure() {
use debug && CMAKE_BUILD_TYPE="Debug"
+ # Fix ld.lld linker error: https://github.com/ROCm/HIP/issues/3382
+ # See also: https://github.com/gentoo/gentoo/pull/29097
+
+ # ideally we want !tc-ld-is-bfd for best future-proofing, but it needs
+ # https://github.com/gentoo/gentoo/pull/28355
+ # mold needs this too but right now tc-ld-is-mold is also not available
+ if tc-ld-is-lld; then
+ append-ldflags -Wl,--undefined-version
+ fi
+
local mycmakeargs=(
-DCMAKE_PREFIX_PATH="$(get_llvm_prefix "${LLVM_MAX_SLOT}")"
-DCMAKE_BUILD_TYPE=${buildtype}