summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2023-12-27 20:50:58 -0500
committerSam James <sam@gentoo.org>2023-12-28 02:18:24 +0000
commitefd05b82186b83e293242463a683385ebdee4f08 (patch)
treebbcc1198175168631acf3045a7a1f6cd30cfb415 /dev-util
parentdev-util/source-highlight: disallow building with LTO (diff)
downloadgentoo-efd05b82186b83e293242463a683385ebdee4f08.tar.gz
gentoo-efd05b82186b83e293242463a683385ebdee4f08.tar.bz2
gentoo-efd05b82186b83e293242463a683385ebdee4f08.zip
dev-util/source-highlight: fix some old formatting quirks
src_* functions should be defined according to order of execution for the aid of the reader. The test phase was defined out of order. Global variables were inconsistently delineated in a huge chunk. Separate them a bit. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/source-highlight/source-highlight-3.1.9-r2.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/dev-util/source-highlight/source-highlight-3.1.9-r2.ebuild b/dev-util/source-highlight/source-highlight-3.1.9-r2.ebuild
index 3a9b22fd5680..055fbbbd12ae 100644
--- a/dev-util/source-highlight/source-highlight-3.1.9-r2.ebuild
+++ b/dev-util/source-highlight/source-highlight-3.1.9-r2.ebuild
@@ -8,6 +8,7 @@ inherit bash-completion-r1 flag-o-matic libtool optfeature
DESCRIPTION="Generate highlighted source code as an (x)html document"
HOMEPAGE="https://www.gnu.org/software/src-highlite/source-highlight.html"
SRC_URI="mirror://gnu/src-highlite/${P}.tar.gz"
+
LICENSE="GPL-3"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
SLOT="0"
@@ -45,6 +46,13 @@ src_configure() {
$(use_enable static-libs static)
}
+src_test() {
+ export LD_LIBRARY_PATH="${S}/lib/srchilite/.libs/"
+ # upstream uses the same temporary filenames in numerous places
+ # see https://bugs.gentoo.org/635100
+ emake -j1 check
+}
+
src_install() {
use doc && local HTML_DOCS=( doc/*.{html,css,java} )
default
@@ -58,13 +66,6 @@ src_install() {
dobashcomp completion/source-highlight
}
-src_test() {
- export LD_LIBRARY_PATH="${S}/lib/srchilite/.libs/"
- # upstream uses the same temporary filenames in numerous places
- # see https://bugs.gentoo.org/635100
- emake -j1 check
-}
-
pkg_postinst() {
optfeature "ctags support" dev-util/ctags
}