summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2024-08-10 17:42:12 -0400
committerMike Pagano <mpagano@gentoo.org>2024-08-16 06:13:37 -0400
commit13e71949c44a6732c5e3d26a02da89d217a45cad (patch)
treeb1eeb0d83873cf1e3fc2120e55afc949b142a9a4 /dev-vcs
parentnet-libs/wslay: add missing pkgconfig bdep (diff)
downloadgentoo-13e71949c44a6732c5e3d26a02da89d217a45cad.tar.gz
gentoo-13e71949c44a6732c5e3d26a02da89d217a45cad.tar.bz2
gentoo-13e71949c44a6732c5e3d26a02da89d217a45cad.zip
dev-vcs/git-filter-repo: add 2.45.0, port to PEP517
Closes: https://bugs.gentoo.org/909982 Signed-off-by: Mike Pagano <mpagano@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/38073 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-filter-repo/Manifest1
-rw-r--r--dev-vcs/git-filter-repo/git-filter-repo-2.45.0.ebuild50
-rw-r--r--dev-vcs/git-filter-repo/metadata.xml5
3 files changed, 55 insertions, 1 deletions
diff --git a/dev-vcs/git-filter-repo/Manifest b/dev-vcs/git-filter-repo/Manifest
index 1c66679a9fa7..fe70e7572310 100644
--- a/dev-vcs/git-filter-repo/Manifest
+++ b/dev-vcs/git-filter-repo/Manifest
@@ -1 +1,2 @@
DIST git-filter-repo-2.38.0.tar.xz 153772 BLAKE2B 491269226c5db9fa57bb5e2038e2c8cb3e82577ff1ba8b34920857c2ec4275d4491e8e17f5bd34e63148ae0d6f7bb57ab3d1d36ffecd390579e0fdc773046d71 SHA512 786c27c1952a5e3625c924e71958cfd61d9065d32754a3e957f258767ccb5b147778c5d499eb82c7c1bf36a2f5a50b1cde372ebbc927aeeedbd713e5ab6563d8
+DIST git-filter-repo-2.45.0.tar.xz 155808 BLAKE2B 44a7ac3ba98e7fdce3a656aca081d8df1ca33acd98be605152fe9b8a9c205bd3b1d8c080769fea56cae54080a6770a447a8a4fbd8dea8b1ec9622b756c76677d SHA512 2fa48a1c6fe285570d02c63d71c92e1a79a4f4dfc0527141b6bed19f4ec27c92f6b98def2c6541bf1fef149e7dd191b023942c99b370b1a5b1555c2cac3e0c42
diff --git a/dev-vcs/git-filter-repo/git-filter-repo-2.45.0.ebuild b/dev-vcs/git-filter-repo/git-filter-repo-2.45.0.ebuild
new file mode 100644
index 000000000000..c14b92677a99
--- /dev/null
+++ b/dev-vcs/git-filter-repo/git-filter-repo-2.45.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Quickly rewrite git repository history (filter-branch replacement)"
+HOMEPAGE="https://github.com/newren/git-filter-repo/"
+SRC_URI="https://github.com/newren/git-filter-repo/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ >=dev-vcs/git-$(ver_cut 1-2)
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+# the git-archive tarball does not have version info; setuptools-scm
+# requires a valid source of version info, this one is for distros
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ cd .. || die
+ bash "${S}"/t/run_tests || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # Just like git itself there is a manpage in troff + html formats.
+ # Unlike git itself, we cannot install the html one, because the
+ # `git --html-path` has the ${PV} of git in it. So just install
+ # the troff copy.
+ doman "${WORKDIR}"/${P}/Documentation/man1/git-filter-repo.1
+
+ # Points to dead symlink
+ rm "${ED}"/usr/share/doc/${PF}/README.md || die
+ rmdir "${ED}"/usr/share/doc/${PF} || die
+
+ dodoc "${WORKDIR}"/${P}/README.md
+}
diff --git a/dev-vcs/git-filter-repo/metadata.xml b/dev-vcs/git-filter-repo/metadata.xml
index 568f4c434329..21462aef87a2 100644
--- a/dev-vcs/git-filter-repo/metadata.xml
+++ b/dev-vcs/git-filter-repo/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>mpagano@gentoo.org</email>
+ <name>Mike Pagano</name>
+ </maintainer>
<stabilize-allarches/>
<upstream>
<remote-id type="github">newren/git-filter-repo</remote-id>