summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-11-19 11:20:11 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-11-19 11:20:11 -0800
commit19b5edb5c8ba989d6eec326fe3876f23379d1594 (patch)
treef9d05510b54628926bf1b26eea1e5af7a37793d9 /dev-vcs
parentdev-python/kombu: 4.6.3 allarches stablized (diff)
downloadgentoo-19b5edb5c8ba989d6eec326fe3876f23379d1594.tar.gz
gentoo-19b5edb5c8ba989d6eec326fe3876f23379d1594.tar.bz2
gentoo-19b5edb5c8ba989d6eec326fe3876f23379d1594.zip
dev-vcs/tig: bump to 2.5.0
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/tig/Manifest1
-rw-r--r--dev-vcs/tig/tig-2.5.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-vcs/tig/Manifest b/dev-vcs/tig/Manifest
index bcd25a783a73..81c254a37834 100644
--- a/dev-vcs/tig/Manifest
+++ b/dev-vcs/tig/Manifest
@@ -1,2 +1,3 @@
DIST tig-2.3.3.tar.gz 1082818 BLAKE2B 0e9bcd02726b004c233a5efd7f58e4fda478dc1d2b738a7f8c086a3d71807d319ac8bd296b0f7c7569ed69a5b2b1db18e5c957cc5ce890a67b8f6ee7ead29551 SHA512 1d1cdf7184eeb3fea301c1959023f4aa97c4f8e25fc96cd61933ca39cf7549b6c7e1d9517f7ffd45d212ae9542ea4be07370b41c623cf6d0db8d025634b1d6d1
DIST tig-2.4.1.tar.gz 1181900 BLAKE2B 85bb76008e5c10e94d97ac4cd88ac4eb2a0675ef5b45e9f21a9d2219cf0b6ed55ce52b579b831bc6c6fc530c89fb99f5dfd1f62dab3e1ab329e132707dccf908 SHA512 516114ed267a9459e356ca1af35c9eba521f9a11e9462cc5120cc7ea8fba4e54ea0a2e8e0ab96263754d6516354c296df541f8e3642392eaeb205cd88428077c
+DIST tig-2.5.0.tar.gz 1143004 BLAKE2B 77ccb2e754335f2ceaf26f1885cbca093d811ca479ef21fed532e43aab710fccfab85f1b5944273f53d9ed5ab0a5917392129c5d96f2c3c20d5da5029367b308 SHA512 26736fe241dd2dac25d5133ed847a7c1dab4bfeaad83af2effc8e523f8c6d8c179fe3ff05cd4343e4b1048c3c50309908aa32e81dd0789e35afe9bd8ff8772ee
diff --git a/dev-vcs/tig/tig-2.5.0.ebuild b/dev-vcs/tig/tig-2.5.0.ebuild
new file mode 100644
index 000000000000..149399f133e2
--- /dev/null
+++ b/dev-vcs/tig/tig-2.5.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/jonas/tig.git"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://github.com/jonas/tig/releases/download/${P}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+fi
+
+DESCRIPTION="text mode interface for git"
+HOMEPAGE="https://jonas.github.io/tig/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test unicode"
+REQUIRED_USE="test? ( unicode )"
+
+DEPEND="
+ sys-libs/ncurses:0=[unicode?]
+ sys-libs/readline:0="
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+[[ ${PV} == "9999" ]] && BDEPEND+=" app-text/asciidoc app-text/xmlto"
+
+# encoding/env issues
+RESTRICT="test"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ econf $(use_with unicode ncursesw)
+}
+
+src_compile() {
+ emake V=1
+ [[ ${PV} == "9999" ]] && emake V=1 doc-man doc-html
+}
+
+src_test() {
+ # workaround parallel test failures
+ emake -j1 test
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-doc-man
+ dodoc doc/manual.html README.html NEWS.html
+ newbashcomp contrib/tig-completion.bash ${PN}
+
+ docinto examples
+ dodoc contrib/*.tigrc
+}