summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/awesomenauts
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/awesomenauts')
-rw-r--r--games-action/awesomenauts/Manifest1
-rw-r--r--games-action/awesomenauts/awesomenauts-2013.5.21.3.ebuild100
-rw-r--r--games-action/awesomenauts/metadata.xml10
3 files changed, 111 insertions, 0 deletions
diff --git a/games-action/awesomenauts/Manifest b/games-action/awesomenauts/Manifest
new file mode 100644
index 000000000000..c71ad8a3f4f2
--- /dev/null
+++ b/games-action/awesomenauts/Manifest
@@ -0,0 +1 @@
+DIST Awesomenauts-Linux-2013-5-21-3.bin 753089168 SHA256 ad35716fd0360ee711d07c67436b654e61157d2eb1c76d7857d0335d8da7a42e SHA512 d69e6fe2ef167fd67492f4a67063bcbe43c42c1a55aed545097959156a5da51500da83b3c0cd5d7221588a9a781eda6e9e9bf63a2e3f1a9202e2980680300ff1 WHIRLPOOL b70c61431f51aea70d1c7cee32109e810e48448ba2e2d7a250b7dcecc34d9ff2d6a9cbf2f94eca6da74a533357d9d0422defb69fec90a6dc07207d35e42b4189
diff --git a/games-action/awesomenauts/awesomenauts-2013.5.21.3.ebuild b/games-action/awesomenauts/awesomenauts-2013.5.21.3.ebuild
new file mode 100644
index 000000000000..544451bba1aa
--- /dev/null
+++ b/games-action/awesomenauts/awesomenauts-2013.5.21.3.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils unpacker games
+
+DESCRIPTION="Team-based competetive arena play"
+HOMEPAGE="http://www.awesomenauts.com/"
+SRC_URI="Awesomenauts-Linux-${PV//./-}.bin"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE="bundled-libs"
+RESTRICT="bindist fetch bundled-libs? ( splitdebug )"
+
+MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${MYGAMEDIR#/}/Awesomenauts.bin.x86
+ ${MYGAMEDIR#/}/Settings.bin.x86
+ ${MYGAMEDIR#/}/lib/*"
+
+RDEPEND="
+ virtual/opengl
+ virtual/glu
+ amd64? (
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ >=virtual/glu-9.0-r1[abi_x86_32(-)]
+ >=media-libs/freetype-2.5.0.1[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ !bundled-libs? (
+ >=media-libs/libtheora-1.1.1[abi_x86_32(-)]
+ >=media-libs/libsdl-1.2.15-r4:0[X,opengl,video,abi_x86_32(-)]
+ >=media-libs/openal-1.15.1[abi_x86_32(-)]
+ >=media-libs/libogg-1.3.0[abi_x86_32(-)]
+ >=media-libs/libvorbis-1.3.3-r1[abi_x86_32(-)]
+ media-gfx/nvidia-cg-toolkit[multilib]
+ )
+ )
+ x86? (
+ media-libs/freetype
+ x11-libs/libX11
+ !bundled-libs? (
+ media-gfx/nvidia-cg-toolkit
+ media-libs/libogg
+ media-libs/libsdl:0[X,opengl,video]
+ media-libs/libtheora
+ media-libs/libvorbis
+ media-libs/openal
+ )
+ )"
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/data
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to ${DISTDIR}"
+ einfo
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_prepare() {
+ if use !bundled-libs ; then
+ rm -rv lib || die
+ fi
+}
+
+src_install() {
+ insinto "${MYGAMEDIR}"
+ doins -r *
+
+ doicon -s 256 AwesomenautsIcon.png
+ make_desktop_entry "${PN}" "Awesomenauts" "AwesomenautsIcon"
+ games_make_wrapper "${PN}" "./Awesomenauts.bin.x86" "${MYGAMEDIR}" "${MYGAMEDIR}/lib"
+ make_desktop_entry "${PN}-settings" "Awesomenauts (settings)" "AwesomenautsIcon"
+ games_make_wrapper "${PN}-settings" "./Settings.bin.x86" "${MYGAMEDIR}" "${MYGAMEDIR}/lib"
+
+ fperms +x "${MYGAMEDIR}"/{Awesomenauts,Settings}.bin.x86
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-action/awesomenauts/metadata.xml b/games-action/awesomenauts/metadata.xml
new file mode 100644
index 000000000000..fcab3b2f70ac
--- /dev/null
+++ b/games-action/awesomenauts/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name='bundled-libs'>
+ Use the upstream provided bundled libraries.
+ </flag>
+ </use>
+</pkgmetadata>