summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/cavezofphear/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/cavezofphear/files')
-rw-r--r--games-arcade/cavezofphear/files/cavezofphear-0.5.1-gentoo.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-arcade/cavezofphear/files/cavezofphear-0.5.1-gentoo.patch b/games-arcade/cavezofphear/files/cavezofphear-0.5.1-gentoo.patch
new file mode 100644
index 000000000000..fbf79af44519
--- /dev/null
+++ b/games-arcade/cavezofphear/files/cavezofphear-0.5.1-gentoo.patch
@@ -0,0 +1,36 @@
+diff -ru phear-0.5.1.orig/Makefile phear-0.5.1/Makefile
+--- phear-0.5.1.orig/Makefile 2007-02-27 06:21:55.000000000 -0500
++++ phear-0.5.1/Makefile 2013-01-18 02:09:56.403224104 -0500
+@@ -2,7 +2,7 @@
+ DESTDIR_DATA = /usr/local/share
+
+ make:
+- cd src && make
++ $(MAKE) -C src phear
+ clean:
+ rm -f phear editor
+ install:
+diff -ru phear-0.5.1.orig/src/Makefile phear-0.5.1/src/Makefile
+--- phear-0.5.1.orig/src/Makefile 2011-12-12 07:26:03.000000000 -0500
++++ phear-0.5.1/src/Makefile 2013-01-18 02:10:48.218423433 -0500
+@@ -2,10 +2,8 @@
+
+ DESTDIR = ..
+
+-CC = gcc
+ INSTALL = install
+-CFLAGS ?= -s -Wall -O2
+-LDFLAGS += -lncurses
++LDLIBS = `pkg-config ncurses --libs`
+
+ all: phear install clean
+
+@@ -13,7 +11,7 @@
+ $(CC) $(CFLAGS) -c $^ -o $@
+
+ phear: $(OBJS)
+- $(CC) $(CFLAGS) -o $@ $^ ${LDFLAGS}
++ $(CC) $(CFLAGS) -o $@ $^ ${LDFLAGS} $(LDLIBS)
+
+ install: install-game
+