summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-05-05 13:10:49 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-05-05 19:37:31 -0400
commitbaa52b0691fe34b51a3e09b5a03e2df68236dc2a (patch)
tree8e71fae1da0ad8f88e04f60def09dfa359df41bf /games-arcade/commandergenius
parentgames-simulation/singularity: enable py3.12 + tidy (diff)
downloadgentoo-baa52b0691fe34b51a3e09b5a03e2df68236dc2a.tar.gz
gentoo-baa52b0691fe34b51a3e09b5a03e2df68236dc2a.tar.bz2
gentoo-baa52b0691fe34b51a3e09b5a03e2df68236dc2a.zip
games-arcade/commandergenius: enable py3.12 + tidy
Still needs the bump that would remove python altogether, but I don't have the game data to run it and would rather not handle it. Adding 3.12 is also pretty tentative. Closes: https://bugs.gentoo.org/929568 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-arcade/commandergenius')
-rw-r--r--games-arcade/commandergenius/commandergenius-2.4.0-r1.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/games-arcade/commandergenius/commandergenius-2.4.0-r1.ebuild b/games-arcade/commandergenius/commandergenius-2.4.0-r1.ebuild
index 82eb3b850b7e..5d2aabf22c41 100644
--- a/games-arcade/commandergenius/commandergenius-2.4.0-r1.ebuild
+++ b/games-arcade/commandergenius/commandergenius-2.4.0-r1.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# note: version >=2.5.0 switches from python to lua
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit cmake flag-o-matic python-single-r1 xdg
-MY_P="Commander-Genius-v${PV}"
+MY_P=Commander-Genius-v${PV}
DESCRIPTION="Open Source Commander Keen clone (needs original game files)"
HOMEPAGE="https://clonekeenplus.sourceforge.io/"
SRC_URI="https://gitlab.com/Dringgstein/Commander-Genius/-/archive/v${PV}/${MY_P}.tar.bz2"
-S="${WORKDIR}/${MY_P}"
+S=${WORKDIR}/${MY_P}
LICENSE="GPL-2"
SLOT="0"
@@ -29,10 +29,12 @@ RDEPEND="
sys-libs/zlib[minizip]
downloader? ( net-misc/curl )
opengl? ( virtual/opengl )
- python? ( ${PYTHON_DEPS} )"
+ python? ( ${PYTHON_DEPS} )
+"
DEPEND="
${RDEPEND}
- dev-libs/boost"
+ dev-libs/boost
+"
BDEPEND="python? ( ${PYTHON_DEPS} )"
PATCHES=(