summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-19 01:26:30 +0100
committerSam James <sam@gentoo.org>2021-08-19 01:39:04 +0100
commit12920b7e75c6f7ce8686c3ffaf67d9108a534e02 (patch)
tree655695e23d3c81a41edebda79f8f1846a33ae62d /games-arcade/sdlroids/sdlroids-1.3.4-r5.ebuild
parentgames-arcade/cosmosmash: add missing dependencies (diff)
downloadgentoo-12920b7e75c6f7ce8686c3ffaf67d9108a534e02.tar.gz
gentoo-12920b7e75c6f7ce8686c3ffaf67d9108a534e02.tar.bz2
gentoo-12920b7e75c6f7ce8686c3ffaf67d9108a534e02.zip
games-arcade/sdlroids: add missing libsdl[joystick] dependency
Closes: https://bugs.gentoo.org/758311 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-arcade/sdlroids/sdlroids-1.3.4-r5.ebuild')
-rw-r--r--games-arcade/sdlroids/sdlroids-1.3.4-r5.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-arcade/sdlroids/sdlroids-1.3.4-r5.ebuild b/games-arcade/sdlroids/sdlroids-1.3.4-r5.ebuild
new file mode 100644
index 000000000000..fef465d97c2e
--- /dev/null
+++ b/games-arcade/sdlroids/sdlroids-1.3.4-r5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop
+
+DESCRIPTION="Asteroids Clone for X using SDL"
+HOMEPAGE="http://david.hedbor.org/projects/sdlroids/"
+SRC_URI="mirror://sourceforge/sdlroids/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libsdl[joystick]
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-sound.patch
+ "${FILESDIR}"/${P}-Makefile.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ newicon icons/sdlroids-48x48.xpm ${PN}.xpm
+ make_desktop_entry ${PN} SDLRoids ${PN}
+}