summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-08-01 22:46:13 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-08-01 22:46:13 +0300
commit5fcf812450e890db0fdb4c4c0f3b33ee544bce2f (patch)
tree7393765f7d8b8404972eeaaf09cb5dc87fdfef09 /games-arcade
parentgames-arcade/xsfcave: treeclean (diff)
downloadgentoo-5fcf812450e890db0fdb4c4c0f3b33ee544bce2f.tar.gz
gentoo-5fcf812450e890db0fdb4c4c0f3b33ee544bce2f.tar.bz2
gentoo-5fcf812450e890db0fdb4c4c0f3b33ee544bce2f.zip
games-arcade/spacerider: treeclean
Closes: https://bugs.gentoo.org/935307 (pkgremoved) Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/spacerider/Manifest1
-rw-r--r--games-arcade/spacerider/files/spacerider-0.13-font.patch14
-rw-r--r--games-arcade/spacerider/files/spacerider-0.13-gcc41.patch10
-rw-r--r--games-arcade/spacerider/files/spacerider-0.13-gcc49.patch22
-rw-r--r--games-arcade/spacerider/files/spacerider-0.13-gentoo.patch27
-rw-r--r--games-arcade/spacerider/files/spacerider-0.13-ovflfix.patch11
-rw-r--r--games-arcade/spacerider/metadata.xml8
-rw-r--r--games-arcade/spacerider/spacerider-0.13-r1.ebuild44
8 files changed, 0 insertions, 137 deletions
diff --git a/games-arcade/spacerider/Manifest b/games-arcade/spacerider/Manifest
deleted file mode 100644
index f637297b26c6..000000000000
--- a/games-arcade/spacerider/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST spacerider-0.13.tar.bz2 283861 BLAKE2B 89687ca24a663addb81af0c775201e1a57e6d524e9fb99766d4003a4401dc406e50c8d103600c57c7d4b30ee620b3ec60089f05aaa4e0ad9da72a6f5e64fd527 SHA512 4f8d506abfe242039247d5c4e43c012ded14f3b18de710aea0c9c6d933cb60fde3116008723d44acadd490b3666e107506fad6ee027d2b31c47d118185e0c03e
diff --git a/games-arcade/spacerider/files/spacerider-0.13-font.patch b/games-arcade/spacerider/files/spacerider-0.13-font.patch
deleted file mode 100644
index 87732a106633..000000000000
--- a/games-arcade/spacerider/files/spacerider-0.13-font.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Ugly brute-force method for avoiding a double-free segfault on exit.
-Better patch welcome.
-
---- a/spacerider.cpp.orig 2015-03-31 23:24:17.770966147 -0400
-+++ b/spacerider.cpp 2015-03-31 23:24:41.592174463 -0400
-@@ -306,8 +306,6 @@
- /* free screen */
- SDL_FreeSurface(screen);
- }
-- /* call the TTF-Library cleanup function */
-- TTF_Quit();
-
- /* call the NET-Library cleanup function */
- SDLNet_Quit();
diff --git a/games-arcade/spacerider/files/spacerider-0.13-gcc41.patch b/games-arcade/spacerider/files/spacerider-0.13-gcc41.patch
deleted file mode 100644
index e5524b6e6430..000000000000
--- a/games-arcade/spacerider/files/spacerider-0.13-gcc41.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/spacerider.cpp.old 2007-02-18 11:25:38.000000000 +0100
-+++ b/spacerider.cpp 2007-02-18 11:27:00.000000000 +0100
-@@ -17,6 +17,7 @@
- #include <unistd.h>
- }
-
-+int send_score_thread(void *param);
-
- Spacerider::Spacerider(const int argc, char *argv[]) : fullscreen(FULLSCREEN), game_over(false), online_highscore(ONLINE_HIGHSCORE), score_sent(false), name_input(true), highscore_thread_started(false), scroll(0), last_enemy(0), score(0), lives(LIVES), fps(FPS)
- {
diff --git a/games-arcade/spacerider/files/spacerider-0.13-gcc49.patch b/games-arcade/spacerider/files/spacerider-0.13-gcc49.patch
deleted file mode 100644
index b4d5ca6d5764..000000000000
--- a/games-arcade/spacerider/files/spacerider-0.13-gcc49.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/effect.cpp.orig 2015-03-31 22:36:53.336131373 -0400
-+++ b/effect.cpp 2015-03-31 22:37:04.359755281 -0400
-@@ -18,7 +18,7 @@
- void Effect::add(const int x, const int y)
- {
- object_struct *effect;
-- if((effect = add_object(x, y)) == NULL)
-+ if((effect = add_object(x, y, 0, 0)) == NULL)
- {
- return;
- }
---- a/object.h.orig 2015-03-31 22:35:22.939214561 -0400
-+++ b/object.h 2015-03-31 22:37:19.654233441 -0400
-@@ -172,7 +172,7 @@
- return object->next;
- }
-
--template <class T>struct Object<T>::object_struct *Object<T>::add_object(const int x, const int y, const int speedx = 0, const int speedy = 0)
-+template <class T>struct Object<T>::object_struct *Object<T>::add_object(const int x, const int y, const int speedx, const int speedy)
- {
- object_struct *object;
-
diff --git a/games-arcade/spacerider/files/spacerider-0.13-gentoo.patch b/games-arcade/spacerider/files/spacerider-0.13-gentoo.patch
deleted file mode 100644
index ecfdcc513cd0..000000000000
--- a/games-arcade/spacerider/files/spacerider-0.13-gentoo.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -3,12 +3,12 @@
- BINDIR=/usr/bin/
- MANDIR=/usr/share/man/man1/
- DATADIR=/usr/share/games/spacerider/
--CXX=g++
-+CXX?=g++
- CP=cp
- MKDIR=mkdir -p
- INSTALL=install
- RM=rm -f
--CXXFLAGS=-Wall -fomit-frame-pointer -O3 `sdl-config --cflags`
-+CXXFLAGS+=$(shell sdl-config --cflags)
- OBJS=main.o globals.o spacerider.o music.o sprite.o enemy.o effect.o visible.o box.o features.o font.o image.o bullet.o
- OUTPUT=spacerider
- LIBS=`sdl-config --libs` -lSDL_image -lSDL_ttf -lSDL_mixer -lSDL_net -lSDL_gfx
-@@ -22,8 +22,7 @@
-
-
- $(OUTPUT): $(OBJS)
-- $(CXX) $(CXXFLAGS) -o $(OUTPUT) $(OBJS) $(LIBS)
-- strip $(OUTPUT)
-+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $(OUTPUT) $(OBJS) $(LIBS)
-
- %.o: %.cpp
- $(CXX) $(CXXFLAGS) -c $<
diff --git a/games-arcade/spacerider/files/spacerider-0.13-ovflfix.patch b/games-arcade/spacerider/files/spacerider-0.13-ovflfix.patch
deleted file mode 100644
index c590400f649f..000000000000
--- a/games-arcade/spacerider/files/spacerider-0.13-ovflfix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/spacerider.cpp.old 2010-10-29 10:12:19.000000000 +0200
-+++ b/spacerider.cpp 2010-10-29 10:13:47.000000000 +0200
-@@ -112,7 +112,7 @@
- break;
- case 'n':
- /* specify a name for the online-highscore */
-- strncpy(name, optarg, 128);
-+ strncpy(name, optarg, sizeof (name));
- online_highscore = true;
- break;
- case 't':
diff --git a/games-arcade/spacerider/metadata.xml b/games-arcade/spacerider/metadata.xml
deleted file mode 100644
index 1c3ba213c494..000000000000
--- a/games-arcade/spacerider/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>games@gentoo.org</email>
- <name>Gentoo Games Project</name>
-</maintainer>
-</pkgmetadata>
diff --git a/games-arcade/spacerider/spacerider-0.13-r1.ebuild b/games-arcade/spacerider/spacerider-0.13-r1.ebuild
deleted file mode 100644
index 8cf24d976f7d..000000000000
--- a/games-arcade/spacerider/spacerider-0.13-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit desktop
-
-DESCRIPTION="Space-shooter written in C++, using the SDL"
-HOMEPAGE="http://www.hackl.dhs.org/spacerider/"
-SRC_URI="mirror://gentoo/${P}.tar.bz2" # stupid php script
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="media-libs/libsdl[sound,video]
- media-libs/sdl-gfx
- media-libs/sdl-mixer
- media-libs/sdl-image[jpeg]
- media-libs/sdl-net
- media-libs/sdl-ttf"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- default
- eapply "${FILESDIR}/${P}"-gentoo.patch \
- "${FILESDIR}/${P}"-gcc41.patch \
- "${FILESDIR}"/${P}-ovflfix.patch \
- "${FILESDIR}"/${P}-gcc49.patch \
- "${FILESDIR}"/${P}-font.patch
- sed -i \
- -e "s:/usr/share/games/spacerider:/usr/share/${PN}:" \
- globals.cpp || die
-}
-
-src_install() {
- dobin ${PN}
- insinto "/usr/share/${PN}"
- doins -r data
- einstalldocs
- newman ${PN}.{1,6}
- newicon data/sprites/star_monster1/1.bmp ${PN}.bmp
- make_desktop_entry ${PN} Spacerider /usr/share/pixmaps/${PN}.bmp
-}