summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-30 00:53:38 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-30 06:30:33 -0400
commit6426c662d000226e0274c4f4d6a61dfcecc740f4 (patch)
tree8ecd3af93859b4f2f148915b843703f6b33aeec1 /games-arcade
parentgames-action/xpilot: force gcc -E for imake's generation (diff)
downloadgentoo-6426c662d000226e0274c4f4d6a61dfcecc740f4.tar.gz
gentoo-6426c662d000226e0274c4f4d6a61dfcecc740f4.tar.bz2
gentoo-6426c662d000226e0274c4f4d6a61dfcecc740f4.zip
games-arcade/xboing: force gcc -E for imake's generation
Requires traditional cpp support and is broken in all sort of ways with clang-cpp / -E. Can still use clang & friends for everything else. Ideally these packages need to be built another way or last rited, imake will just accumulate more problems. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/xboing/xboing-2.4-r3.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/games-arcade/xboing/xboing-2.4-r3.ebuild b/games-arcade/xboing/xboing-2.4-r3.ebuild
index 354b48020f56..40988b31ee7c 100644
--- a/games-arcade/xboing/xboing-2.4-r3.ebuild
+++ b/games-arcade/xboing/xboing-2.4-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,6 +21,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="
app-text/rman
+ sys-devel/gcc
x11-misc/gccmakedep
>=x11-misc/imake-1.0.8-r1"
@@ -40,7 +41,7 @@ src_configure() {
append-cflags -fcommon #707214
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
- IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf -a || die
+ IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf -a || die
}
src_compile() {