summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2024-04-20 16:58:18 +0300
committerMart Raudsepp <leio@gentoo.org>2024-04-20 17:36:16 +0300
commitda4e37eab52d05e8c79cfc193bb24b7df438bb95 (patch)
tree63b4eb216a88e2ec9cd0e2346fdce70f87736637 /games-arcade
parentapp-arch/file-roller: add 44.1 (diff)
downloadgentoo-da4e37eab52d05e8c79cfc193bb24b7df438bb95.tar.gz
gentoo-da4e37eab52d05e8c79cfc193bb24b7df438bb95.tar.bz2
gentoo-da4e37eab52d05e8c79cfc193bb24b7df438bb95.zip
games-arcade/gnome-nibbles: add 4.0.4
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/gnome-nibbles/Manifest1
-rw-r--r--games-arcade/gnome-nibbles/gnome-nibbles-4.0.4.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/games-arcade/gnome-nibbles/Manifest b/games-arcade/gnome-nibbles/Manifest
index ea10ac16e111..ba8d3f524772 100644
--- a/games-arcade/gnome-nibbles/Manifest
+++ b/games-arcade/gnome-nibbles/Manifest
@@ -1 +1,2 @@
DIST gnome-nibbles-4.0.2.tar.xz 418992 BLAKE2B d94e0c11c683765ff50ec4c72669b6ccdac405a107d1f68675b95ae386ff3ae825e0783ce45f26e974675a243d98a00bb1be224ae29e5f25e3735cf1bbf25990 SHA512 a0f82e4860cc05f9b2fdd2037a59088ef1747e17f660778ba68d6eed328b962e27606dfe2e7a9b0a8f46c68bb5f6ff26f7048fae24ab17fe8d63685656e85025
+DIST gnome-nibbles-4.0.4.tar.xz 419784 BLAKE2B 5ddecac8818fe512d84a4d007aa91b2bb747686f3d8471ed4f57b02584755ab0b87f4b479ab445e1197187a7d9a429e6489dd57a9434f7a1a7b7b3d02bee34ba SHA512 751dc492d5facd769e81478e93c55afe7c9a8e64a31e224568d67188cdd07fe568709ee211fe18452e10aa7224d5104284c53b95b52f8721a8e0ec28fe7823cc
diff --git a/games-arcade/gnome-nibbles/gnome-nibbles-4.0.4.ebuild b/games-arcade/gnome-nibbles/gnome-nibbles-4.0.4.ebuild
new file mode 100644
index 000000000000..fa838bb0042b
--- /dev/null
+++ b/games-arcade/gnome-nibbles/gnome-nibbles-4.0.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Nibbles clone for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Nibbles https://gitlab.gnome.org/GNOME/gnome-nibbles"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.78.0:2
+ dev-libs/libgee:0.8=
+ >=media-libs/gsound-1.0.2
+ >=gui-libs/gtk-4.6:4
+ x11-libs/pango
+ >=dev-libs/libgnome-games-support-2.0.0:2=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+ media-libs/gsound[vala]
+"
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}