summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-09-22 09:29:22 -0700
committerJoonas Niilola <juippis@gentoo.org>2024-11-02 14:46:00 +0200
commitd9960ee4782d960b94bc39b2af7c7a1e004381a5 (patch)
tree9959d52f3cfb01e7a8c8d1d33fb5920d5d40d1c1 /games-emulation/bsnes-jg
parentgames-emulation/bsnes-jg: add new USE flags (diff)
downloadgentoo-d9960ee4782d960b94bc39b2af7c7a1e004381a5.tar.gz
gentoo-d9960ee4782d960b94bc39b2af7c7a1e004381a5.tar.bz2
gentoo-d9960ee4782d960b94bc39b2af7c7a1e004381a5.zip
games-emulation/bsnes-jg: add 2.0.0
Signed-off-by: orbea <orbea@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'games-emulation/bsnes-jg')
-rw-r--r--games-emulation/bsnes-jg/Manifest1
-rw-r--r--games-emulation/bsnes-jg/bsnes-jg-2.0.0.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/games-emulation/bsnes-jg/Manifest b/games-emulation/bsnes-jg/Manifest
index 8fa3da84c341..d57ef55561ba 100644
--- a/games-emulation/bsnes-jg/Manifest
+++ b/games-emulation/bsnes-jg/Manifest
@@ -1,2 +1,3 @@
DIST bsnes-1.1.2.tar.bz2 4183035 BLAKE2B 09e01845fb9e6208f5262e2abef14c46e9fa53cfdd025821345507fc68e520dc21ca69e5d712a7f821936166975865c26dc0be42549b551abdbb941e748949b1 SHA512 77cb82b6cba2941813de25273bd74b928ad380dccadb909ae3500ddf6f8906504f5400df95381569d35fc7b06e0330f9eb4d54d88d64a5c698925d54df62bada
DIST bsnes-1.2.0.tar.bz2 4277380 BLAKE2B 03abb6efdf2e2fe487ddea780f9a3053092e718695d7f875304a008f5e3e967c443f3ad40d7c8a82b07d66c52ead5d258018fd004cb205efaaa872b122057c98 SHA512 96aaeecf10508bc7672c30fa24b34e0d32e34c4190928109a141f4a1d73fb6f007844f9b7154ffc57028ddb9e99b5c281a214b9517ce5de618cf229722ff1e20
+DIST bsnes-2.0.0.tar.bz2 4318300 BLAKE2B 7b93502a7dd68427069d0a33161927709f327352a3da3637cea416b31293750b249f3d750bba093a5a3430c5c2ab42b5e29e8b707377b29254651091a2b0aaed SHA512 95f970a16c7efdfd5f0dca1a8bcfd7d5785e4e2635eb4c36fdade350be52c8c950736df84a9a5bb108a98c4b9b936f12f2a0ea7d9974737e105b1b0c034f6dbd
diff --git a/games-emulation/bsnes-jg/bsnes-jg-2.0.0.ebuild b/games-emulation/bsnes-jg/bsnes-jg-2.0.0.ebuild
new file mode 100644
index 000000000000..261d967b3f3f
--- /dev/null
+++ b/games-emulation/bsnes-jg/bsnes-jg-2.0.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOCS_BUILDER="doxygen"
+DOCS_DIR="objs/doc"
+
+inherit docs toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Fork of bsnes"
+HOMEPAGE="https://gitlab.com/jgemu/bsnes"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="
+ ISC GPL-3+ LGPL-2.1+ MIT ZLIB
+ examples? ( 0BSD )
+"
+SLOT="1"
+IUSE="examples +jgmodule shared"
+REQUIRED_USE="
+ || ( examples jgmodule shared )
+ doc? ( shared )
+"
+
+DEPEND="
+ media-libs/libsamplerate
+ examples? ( media-libs/libsdl2[sound,video] )
+ jgmodule? ( media-libs/jg:1= )
+"
+RDEPEND="
+ ${DEPEND}
+ jgmodule? ( games-emulation/jgrf )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local makeopts=(
+ PREFIX="${EPREFIX}"/usr
+ DISABLE_MODULE=$(usex jgmodule 0 1)
+ ENABLE_EXAMPLE=$(usex examples 1 0)
+ ENABLE_SHARED=$(usex shared 1 0)
+ )
+ export MY_MAKEOPTS="${makeopts[@]}"
+}
+
+src_compile() {
+ local mymakeargs=(
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+ ${MY_MAKEOPTS}
+ )
+ emake "${mymakeargs[@]}"
+ use doc && emake doxyfile
+ docs_compile
+}
+
+src_install() {
+ local mymakeargs=(
+ DESTDIR="${D}"
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF}
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+ ${MY_MAKEOPTS}
+ )
+ emake install "${mymakeargs[@]}"
+ use doc && einstalldocs
+}