summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-11-29 03:42:33 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-11-29 03:42:46 -0500
commit4c42ae0bdcccf4167901bd990378a3dce63fd3f4 (patch)
tree20245ef863a4b38659fc795deae382f8347babad /games-emulation/desmume/desmume-0.9.11.ebuild
parentpython-utils-r1.eclass: Reduce python_do*/new* ban to EAPI < 4 (diff)
downloadgentoo-4c42ae0bdcccf4167901bd990378a3dce63fd3f4.tar.gz
gentoo-4c42ae0bdcccf4167901bd990378a3dce63fd3f4.tar.bz2
gentoo-4c42ae0bdcccf4167901bd990378a3dce63fd3f4.zip
version bump (bug #566870)
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'games-emulation/desmume/desmume-0.9.11.ebuild')
-rw-r--r--games-emulation/desmume/desmume-0.9.11.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-emulation/desmume/desmume-0.9.11.ebuild b/games-emulation/desmume/desmume-0.9.11.ebuild
new file mode 100644
index 000000000000..204a6e57247d
--- /dev/null
+++ b/games-emulation/desmume/desmume-0.9.11.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit games
+
+DESCRIPTION="Nintendo DS emulator"
+HOMEPAGE="http://desmume.org/"
+SRC_URI="mirror://sourceforge/desmume/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.8.0:2
+ gnome-base/libglade
+ x11-libs/gtkglext
+ virtual/opengl
+ sys-libs/zlib
+ dev-libs/zziplib
+ media-libs/libsdl[joystick,opengl,video]
+ x11-libs/agg"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ egamesconf --datadir=/usr/share
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README README.LIN" \
+ default
+ prepgamesdirs
+}