summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2023-08-09 08:14:28 -0700
committerSam James <sam@gentoo.org>2023-08-29 07:08:43 +0100
commit90e9942f30b00eecc5f3b7f3cf4036e051e50c6d (patch)
tree8c043daee61de513f558b18760d30e5d999a0c15 /games-emulation/jgrf/jgrf-1.0.2.ebuild
parentgames-emulation/jgemu: new use, geolith (diff)
downloadgentoo-90e9942f30b00eecc5f3b7f3cf4036e051e50c6d.tar.gz
gentoo-90e9942f30b00eecc5f3b7f3cf4036e051e50c6d.tar.bz2
gentoo-90e9942f30b00eecc5f3b7f3cf4036e051e50c6d.zip
games-emulation/jgrf: remove erroneous dependency
The dependency on dev-libs/openssl is only for the MD5 Message-Digest Algorithm (RFC 1321) functions. Closes: https://bugs.gentoo.org/912235 Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/32233 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-emulation/jgrf/jgrf-1.0.2.ebuild')
-rw-r--r--games-emulation/jgrf/jgrf-1.0.2.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/games-emulation/jgrf/jgrf-1.0.2.ebuild b/games-emulation/jgrf/jgrf-1.0.2.ebuild
deleted file mode 100644
index b52af23a4df0..000000000000
--- a/games-emulation/jgrf/jgrf-1.0.2.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs xdg
-
-DESCRIPTION="The Jolly Good Reference Frontend"
-HOMEPAGE="https://jgemu.gitlab.io/jgrf.html"
-if [[ "${PV}" == *9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://gitlab.com/jgemu/${PN}.git"
-else
- SRC_URI="https://gitlab.com/jgemu/${PN}/-/archive/${PV}/${P}.tar.bz2"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="BSD CC0-1.0 MIT ZLIB"
-SLOT="1"
-
-DEPEND="
- dev-libs/miniz
- dev-libs/openssl:0=[-bindist(-)]
- media-libs/jg:1=
- media-libs/libepoxy[egl]
- media-libs/libsdl2[opengl,sound,video]
- media-libs/speexdsp
-"
-RDEPEND="${DEPEND}"
-BDEPEND="
- virtual/pkgconfig
-"
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- PKG_CONFIG="$(tc-getPKG_CONFIG)" \
- PREFIX="${EPREFIX}"/usr \
- LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
- USE_EXTERNAL_MD5=1 \
- USE_EXTERNAL_MINIZ=1
-}
-
-src_install() {
- emake install \
- DESTDIR="${D}" \
- PREFIX="${EPREFIX}"/usr \
- DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
- USE_EXTERNAL_MD5=1 \
- USE_EXTERNAL_MINIZ=1
-}