summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-12-27 17:16:16 -0800
committerSam James <sam@gentoo.org>2023-01-15 14:16:13 +0000
commit481a8ac8c3c48ee23fb0472e28acc7bc40a94e0c (patch)
treeee2d4961d416cb0e316ee94ea26b3e21e9aef0da /games-emulation
parentgames-emulation/jollycv-jg: New package, v1.0.1 (diff)
downloadgentoo-481a8ac8c3c48ee23fb0472e28acc7bc40a94e0c.tar.gz
gentoo-481a8ac8c3c48ee23fb0472e28acc7bc40a94e0c.tar.bz2
gentoo-481a8ac8c3c48ee23fb0472e28acc7bc40a94e0c.zip
games-emulation/mednafen-jg: New package, v1.31.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mednafen-jg/Manifest1
-rw-r--r--games-emulation/mednafen-jg/mednafen-jg-1.31.0.ebuild67
-rw-r--r--games-emulation/mednafen-jg/mednafen-jg-9999.ebuild67
-rw-r--r--games-emulation/mednafen-jg/metadata.xml23
4 files changed, 158 insertions, 0 deletions
diff --git a/games-emulation/mednafen-jg/Manifest b/games-emulation/mednafen-jg/Manifest
new file mode 100644
index 000000000000..26455fef4a44
--- /dev/null
+++ b/games-emulation/mednafen-jg/Manifest
@@ -0,0 +1 @@
+DIST mednafen-1.31.0.tar.bz2 4400375 BLAKE2B 691d449f55cf2702bdeed06470a1e56507ee09407929e1d742996f54212146a2cdd96e6e31a30ca8d94e807ea95c3a2766297df0f0a38e9c1d28e6615705b536 SHA512 908bdd717b916066f3fca46019fa70c789adf0b159250d3ea3b485ca30c8e41e1b86274bf857530943189461ec8165dcd5242456cbf2e259341731af33f00dfa
diff --git a/games-emulation/mednafen-jg/mednafen-jg-1.31.0.ebuild b/games-emulation/mednafen-jg/mednafen-jg-1.31.0.ebuild
new file mode 100644
index 000000000000..0c98a116fa35
--- /dev/null
+++ b/games-emulation/mednafen-jg/mednafen-jg-1.31.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Port of Mednafen"
+HOMEPAGE="https://gitlab.com/jgemu/mednafen"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD GPL-2 GPL-2+ LGPL-2.1+ ZLIB"
+SLOT="1"
+
+DEPEND="
+ app-arch/zstd
+ dev-libs/lzo:2
+ >=dev-libs/trio-1.17
+ media-libs/flac
+ media-libs/jg:1=
+ sys-libs/zlib:=[minizip]
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ cd jollygood/conf || die
+ eautoreconf
+}
+
+src_configure() {
+ cd jollygood/conf || die
+ econf
+}
+
+src_compile() {
+ emake -C jollygood \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)" \
+ USE_EXTERNAL_TRIO=1
+}
+
+src_install() {
+ emake -C jollygood install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ USE_EXTERNAL_TRIO=1
+}
diff --git a/games-emulation/mednafen-jg/mednafen-jg-9999.ebuild b/games-emulation/mednafen-jg/mednafen-jg-9999.ebuild
new file mode 100644
index 000000000000..0c98a116fa35
--- /dev/null
+++ b/games-emulation/mednafen-jg/mednafen-jg-9999.ebuild
@@ -0,0 +1,67 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Port of Mednafen"
+HOMEPAGE="https://gitlab.com/jgemu/mednafen"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD GPL-2 GPL-2+ LGPL-2.1+ ZLIB"
+SLOT="1"
+
+DEPEND="
+ app-arch/zstd
+ dev-libs/lzo:2
+ >=dev-libs/trio-1.17
+ media-libs/flac
+ media-libs/jg:1=
+ sys-libs/zlib:=[minizip]
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ cd jollygood/conf || die
+ eautoreconf
+}
+
+src_configure() {
+ cd jollygood/conf || die
+ econf
+}
+
+src_compile() {
+ emake -C jollygood \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)" \
+ USE_EXTERNAL_TRIO=1
+}
+
+src_install() {
+ emake -C jollygood install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ USE_EXTERNAL_TRIO=1
+}
diff --git a/games-emulation/mednafen-jg/metadata.xml b/games-emulation/mednafen-jg/metadata.xml
new file mode 100644
index 000000000000..9e58d71f9c1a
--- /dev/null
+++ b/games-emulation/mednafen-jg/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>orbea@riseup.net</email>
+ <name>orbea</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ The Jolly Good API port of Mednafen has emulators for
+ Atari Lynx, Nintendo Virtual Boy, NEC PC Engine/TurboGrafx-16
+ NEC PC Engine CD/TurboDuo, NEC SuperGrafx, Sony PlayStation
+ Sega Saturn, Super Nintendo Entertainment System/Super Famicom
+ SNK Neo Geo Pocket Color and Bandai WonderSwan/Color.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://gitlab.com/jgemu/mednafen/-/issues</bugs-to>
+ <remote-id type="gitlab">jgemu/mednafen</remote-id>
+ </upstream>
+</pkgmetadata>