summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-10-20 09:30:08 -0700
committerEli Schwartz <eschwartz@gentoo.org>2024-11-26 00:03:32 -0500
commitfac901afa92e1ea1687dc7da0fbc683066716d86 (patch)
tree80ea659c9fac656fc20851027ed75f3b72903b01 /games-emulation
parentgames-emulation/rmg: use pkg-config for SDL2 (diff)
downloadgentoo-fac901afa92e1ea1687dc7da0fbc683066716d86.tar.gz
gentoo-fac901afa92e1ea1687dc7da0fbc683066716d86.tar.bz2
gentoo-fac901afa92e1ea1687dc7da0fbc683066716d86.zip
games-emulation/rmg: don't hard-code pkg-config
Closes: https://bugs.gentoo.org/941889 Upstream-PR: https://github.com/raphnet/mupen64plus-input-raphnetraw/pull/17 Upstream-PR: https://github.com/Rosalie241/RMG/pull/296 Upstream-Commit: https://github.com/Rosalie241/RMG/commit/f6b73b86c6625fa5a268b74b1e36114a5bdd535c Signed-off-by: orbea <orbea@riseup.net> Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/rmg/files/rmg-0.6.6-mupen64plus-input-raphnetraw-pkgconfig.patch59
-rw-r--r--games-emulation/rmg/rmg-0.6.6-r1.ebuild5
-rw-r--r--games-emulation/rmg/rmg-9999.ebuild3
3 files changed, 65 insertions, 2 deletions
diff --git a/games-emulation/rmg/files/rmg-0.6.6-mupen64plus-input-raphnetraw-pkgconfig.patch b/games-emulation/rmg/files/rmg-0.6.6-mupen64plus-input-raphnetraw-pkgconfig.patch
new file mode 100644
index 000000000000..0e179046bf40
--- /dev/null
+++ b/games-emulation/rmg/files/rmg-0.6.6-mupen64plus-input-raphnetraw-pkgconfig.patch
@@ -0,0 +1,59 @@
+https://bugs.gentoo.org/941889
+https://github.com/raphnet/mupen64plus-input-raphnetraw/pull/17
+https://github.com/Rosalie241/RMG/pull/296
+https://github.com/Rosalie241/RMG/pull/297
+https://github.com/Rosalie241/RMG/commit/f6b73b86c6625fa5a268b74b1e36114a5bdd535c
+https://github.com/Rosalie241/RMG/commit/69c24b9131909c338b03c48438744b253501146a
+
+From e8ec98eb7e7ee4b769232ce143af6c6f9cf29bc6 Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Sun, 20 Oct 2024 08:59:56 -0700
+Subject: [PATCH 1/2] 3rdParty: don't hard-code pkg-config in
+ mupen64plus-input-raphnetraw (#296) 3rdParty: improve the hidapi check in
+ mupen64plus-input-raphnetraw (#297)
+
+---
+ .../projects/unix/Makefile | 22 ++++++++++---------
+ 1 file changed, 12 insertions(+), 10 deletions(-)
+
+diff --git a/Source/3rdParty/mupen64plus-input-raphnetraw/projects/unix/Makefile b/Source/3rdParty/mupen64plus-input-raphnetraw/projects/unix/Makefile
+index a2571378..18dcaf19 100644
+--- a/Source/3rdParty/mupen64plus-input-raphnetraw/projects/unix/Makefile
++++ b/Source/3rdParty/mupen64plus-input-raphnetraw/projects/unix/Makefile
+@@ -141,6 +141,14 @@ ifeq ($(OS), OSX)
+ endif
+ endif
+
++# test for essential build dependencies
++ifeq ($(origin PKG_CONFIG), undefined)
++ PKG_CONFIG = $(CROSS_COMPILE)pkg-config
++ ifeq ($(shell which $(PKG_CONFIG) 2>/dev/null),)
++ $(error $(PKG_CONFIG) not found)
++ endif
++endif
++
+ ifeq ($(OS), LINUX)
+ HIDAPI_NAME=hidapi-hidraw
+ else
+@@ -149,17 +157,11 @@ endif
+
+ # test for presence of HIDLIB
+ ifeq ($(origin HID_CFLAGS) $(origin HID_LDLIBS), undefined undefined)
+- HIDAPI_CONFIG = $(CROSS_COMPILE)pkg-config $(HIDAPI_NAME)
+- ifeq ($(shell which $(HIDAPI_CONFIG) 2>/dev/null),)
+- HIDAPI_CONFIG = $(CROSS_COMPILE)pkg-config $(HIDAPI_NAME)
+- ifeq ($(shell which $(HIDAPI_CONFIG) 2>/dev/null),)
+- $(error No HIDAPI development libraries found!)
+- else
+- $(warning Using HIDAPI libraries)
+- endif
++ ifeq ($(shell $(PKG_CONFIG) --modversion $(HIDAPI_NAME) 2>/dev/null),)
++ $(error No HIDAPI development libraries found!)
+ endif
+- HID_CFLAGS += $(shell $(HIDAPI_CONFIG) --cflags)
+- HID_LDLIBS += $(shell $(HIDAPI_CONFIG) --libs)
++ HID_CFLAGS = $(shell $(PKG_CONFIG) --cflags $(HIDAPI_NAME))
++ HID_LDLIBS = $(shell $(PKG_CONFIG) --libs $(HIDAPI_NAME))
+ endif
+ CFLAGS += $(HID_CFLAGS)
+ LDLIBS += $(HID_LDLIBS)
diff --git a/games-emulation/rmg/rmg-0.6.6-r1.ebuild b/games-emulation/rmg/rmg-0.6.6-r1.ebuild
index 0ce9716765c4..fa4ced9b12cc 100644
--- a/games-emulation/rmg/rmg-0.6.6-r1.ebuild
+++ b/games-emulation/rmg/rmg-0.6.6-r1.ebuild
@@ -27,7 +27,7 @@ CRATES="
winapi@0.3.9
"
-inherit cargo cmake flag-o-matic xdg
+inherit cargo cmake flag-o-matic toolchain-funcs xdg
MY_PN="${PN^^}"
MY_P="${MY_PN}-${PV}"
@@ -78,6 +78,8 @@ PATCHES=(
"${FILESDIR}"/${PN}-0.5.6-parallel-rdp-standalone-musl.patch
# Use pkg-config(1) for SDL2 and don't depend on which(1)
"${FILESDIR}"/${P}-mupen64plus-core-sdl-pkgconfig.patch
+ # https://bugs.gentoo.org/941889
+ "${FILESDIR}"/${P}-mupen64plus-input-raphnetraw-pkgconfig.patch
)
pkg_setup() {
@@ -127,6 +129,7 @@ src_configure() {
append-flags -fno-strict-aliasing
filter-lto
+ export PKG_CONFIG="$(tc-getPKG_CONFIG)"
export PKG_CONFIG_ALLOW_CROSS=1
local mycmakeargs=(
diff --git a/games-emulation/rmg/rmg-9999.ebuild b/games-emulation/rmg/rmg-9999.ebuild
index eed49326ebd4..bd56ccdd299f 100644
--- a/games-emulation/rmg/rmg-9999.ebuild
+++ b/games-emulation/rmg/rmg-9999.ebuild
@@ -27,7 +27,7 @@ CRATES="
winapi@0.3.9
"
-inherit cargo cmake flag-o-matic xdg
+inherit cargo cmake flag-o-matic toolchain-funcs xdg
MY_PN="${PN^^}"
MY_P="${MY_PN}-${PV}"
@@ -125,6 +125,7 @@ src_configure() {
append-flags -fno-strict-aliasing
filter-lto
+ export PKG_CONFIG="$(tc-getPKG_CONFIG)"
export PKG_CONFIG_ALLOW_CROSS=1
local mycmakeargs=(